History and current browsing state lost after a crash

RESOLVED DUPLICATE of bug 63292

Status

()

defect
RESOLVED DUPLICATE of bug 63292
17 years ago
4 years ago

People

(Reporter: joshgold, Assigned: radha)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
buildID 2002031103

It's difficult to recover what one is working on after a crash.
(my assigned severity refers to the bug.  the feature is less severe.)

a) the bug: history seems not to get committed to disk often enough, so that
after a crash I can lose a whole session's worth of pages I was looking at and
have to find them from scratch.

b) feature suggestion: it would be nice to be able to recover full browser state
(all the pages currently being viewed.)  one version of this is Opera's way,
where when you quit the browser you can save all the windows and come back to
them on restart.  I would also like to be able to actively save in the middle of
work either my whole browser state or one window full of tabs.  Perhaps this
would be a special sort of bookmark.  (I find myself grouping tasks with
multiple webpages into windows of tabs.)
the feature suggestion is partially implemented (you can bookmark a window-full
of tabs using bookmark groups) and is partially bug 36810.

The bug is a duplicate of "session additions to global history lost on crash"

*** This bug has been marked as a duplicate of 63292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
No longer blocks: 1155804
You need to log in before you can comment on or make changes to this bug.