Closed Bug 1395581 Opened 5 years ago Closed 5 years ago

Web Audio API crashes in `anonymous namespace''::handle_channel_layout if running with a 5.1 channel setup

Categories

(Core :: Web Audio, defect)

57 Branch
x86_64
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1394873
Tracking Status
firefox57 --- affected

People

(Reporter: jujjyl, Unassigned)

Details

I'm trying out Web Audio API on a 5.1 channel setup on Windows. Audio is connected via HDMI on Windows, and audio playback device is configured to 5.1 setup in Windows Sound settings, via:

1. Right-click on sound icon at bottom right tray
2. Choose "Playback devices"
3. Choose 5.1 audio output and choose Configure
4. Choose 5.1 Surround
5. Check boxes "Center", "Subwoofer", "Side pair"
6. Check boxes "Front left and right" and "Surround speakers" in the "Full-range speakers" menu.
7. Visit any Web Audio API utilizing page, e.g. Audio Tag in http://webaudioapi.com/samples/

The following crash reports were captured:

https://crash-stats.mozilla.com/report/index/8ae2f71d-9a96-4ddb-bb72-0ddb50170831
https://crash-stats.mozilla.com/report/index/48653399-14b8-4b7b-99a6-5c98b0170831
The crash does not occur on Firefox Stable channel 55.0.3 (32-bit)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394873
You need to log in before you can comment on or make changes to this bug.