[Webrender] Add-on icons on toolbar have empty menus

RESOLVED DUPLICATE of bug 1390741

Status

()

Core
Graphics: WebRender
RESOLVED DUPLICATE of bug 1390741
3 months ago
3 months ago

People

(Reporter: streetwolf, Unassigned)

Tracking

(Blocks: 1 bug)

57 Branch
Points:
---

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
All my Add-ons that have an icon on the toolbar display an empty meny when I click on the icon.  I am on the latest inbound release which should have all the Webrender fixes to date.
(Reporter)

Updated

3 months ago
Component: General → Graphics: WebRender
Product: Firefox → Core
(Reporter)

Comment 1

3 months ago
Created attachment 8903175 [details]
Empty Add-on menus with Webrender enabled.
(Reporter)

Comment 2

3 months ago
Here's what I did in about:config to enable Webrender as per https://mozillagfx.wordpress.com/2017/08/16/webrender-newsletter-1/

turn off layers.async-pan-zoom.enabled
turn on gfx.webrender.enabled
turn on gfx.webrendest.enabled
turn on gfx.webrender.layers-free
turn on gfx.webrender.blob-images
(Reporter)

Comment 3

3 months ago
FYI... WR is much more responsive now.  It's almost usuable except for this menu problem and ocasional hangs.
Was this always broken, or is it a recent regression? If it's a regression, can you use mozregression to find the regression window?
(Reporter)

Comment 5

3 months ago
The problem with using mozregression, as far as my experience with it, is that Fx keeps restarting in safe-mode in order to pinpoint the 'bad' version.  However, this disables all add-ons so I won't have any add-on icons to test with. If I am wrong let me know.
It depends how you are running mozregression. If from the command line there are options to manage how it deals with profiles. Normally it will run with a clean profile every time, which is why you get the "safe mode" experience. But if you run with --profile-persistence=reuse it will reuse the same profile for each run. In your case I think the best would be to just pass -P <PATH> to point to your profile, and use the default of --profile-persistence=clone. This will make a clone of your current profile for each run. You might want to back up the profile before doing this, just in case it screws up.
(Reporter)

Comment 7

3 months ago
For starters I went back to an August 1st version on inbound and had the same problem.
Blocks: 1386665
(Reporter)

Comment 8

3 months ago
I'm trying to get someone who is great at finding regressions.

Comment 9

3 months ago
I found a similar bug here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1390741

Can you try setting extensions.webextensions.remote to false and see if that changes it?
(Reporter)

Comment 10

3 months ago
(In reply to EVP from comment #9)
> I found a similar bug here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1390741
> 
> Can you try setting extensions.webextensions.remote to false and see if that
> changes it?

Yes, setting it to false does fix the problem. Besides displaying the menus again is their any other affect setting it to false?  Can I leave it as false if I disable WR if WR gives me troubles?

Updated

3 months ago
See Also: → bug 1390741
Priority: -- → P3

Updated

3 months ago
Priority: P3 → P2
Whiteboard: [wr-mvp]
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
(In reply to Gary [:streetwolf] from comment #10)
> Yes, setting it to false does fix the problem. Besides displaying the menus
> again is their any other affect setting it to false?  Can I leave it as
> false if I disable WR if WR gives me troubles?

I believe it changes which process the webextension stuff runs in. In general you want that pref to be whatever the default value is. For now running with it false is probably ok, but that will likely be deprecated after a few releases as we get the feature working properly everywhere.

That being said I'm going to dupe this to bug 1390741 which seems to be basically the same thing (sorry I should have remembered that one instead of asking for a regression window).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
See Also: bug 1390741
Duplicate of bug: 1390741

Updated

3 months ago
Priority: P2 → --
Whiteboard: [wr-mvp]
You need to log in before you can comment on or make changes to this bug.