Intermittent browser/base/content/test/alerts/browser_notification_open_settings.js | leaked 2 window(s) until shutdown [url = about:preferences#privacy]

RESOLVED FIXED in Firefox 57

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: rickychien)

Tracking

({intermittent-failure})

unspecified
mozilla57
intermittent-failure
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [photon-preference])

Attachments

(1 attachment)

Duplicate of this bug: 1395809
This started on autoland suspiciously close to when bug 1349689 landed.
Flags: needinfo?(rchien)
22 failures in 62 pushes (0.355 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* try: 22

Platform breakdown:
* linux64-stylo: 7
* linux32: 7
* linux32-stylo: 6
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1395807&startday=2017-09-02&endday=2017-09-02&tree=all
28 failures in 939 pushes (0.03 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 22
* autoland: 4
* mozilla-inbound: 2

Platform breakdown:
* linux64-stylo: 9
* linux32: 8
* linux64: 6
* linux32-stylo: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1395807&startday=2017-08-28&endday=2017-09-03&tree=all
(Assignee)

Updated

a year ago
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: needinfo?(rchien)
Whiteboard: [photon-preference][triage]

Updated

a year ago
Flags: qe-verify-
Priority: P5 → P1
Comment hidden (mozreview-request)
It was a mistake in bug 1349689 that using "sync-pane-loaded" mechanism to wait for preferences pane load has removed accidentally . I'm going to revert it back and see if that fix this intermittent.

Updated

a year ago
Whiteboard: [photon-preference][triage] → [photon-preference]
See try result:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ba7b1f145b9a&group_state=expanded

The latest failure rate is only 3% from OrangeFactor Robot comment 4 (0.03 failures/push), I've re-try many times on try and let's wait and see whether the patch fixes the failure.

Comment 8

a year ago
mozreview-review
Comment on attachment 8904447 [details]
Bug 1395807 - Waiting for "sync-pane-loaded" event for fixing browser_notification_open_settings intermittent

https://reviewboard.mozilla.org/r/176300/#review181952
Attachment #8904447 - Flags: review?(jaws) → review+

Comment 9

a year ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76dfca6d5a33
Waiting for "sync-pane-loaded" event for fixing browser_notification_open_settings intermittent r=jaws
https://hg.mozilla.org/mozilla-central/rev/76dfca6d5a33
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
6 failures in 924 pushes (0.006 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 4
* try: 1
* mozilla-inbound: 1

Platform breakdown:
* windows7-32: 2
* linux64-stylo-disabled: 2
* linux64-stylo: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1395807&startday=2017-09-04&endday=2017-09-10&tree=all
Seems like the failure rate has descended to 0 since Sep 7.
You need to log in before you can comment on or make changes to this bug.