There is a black flicker when you minimize a window that is in full screen

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Ovidiu, Unassigned)

Tracking

57 Branch
All
Unspecified
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8903510 [details]
Recording #20.mp4

[Affected versions]:

Tested on Nightly 57.0a1(2017-08-31)

[Affected platforms]:

This issue is more visible on Mac OS X 10.12, but we also tested on other OSes and we encounter this problem.

[Steps to reproduce]:


1. Visit any site that you want for example use this:http://www.business-review.eu/business-review-supplements-guides
2. Make the window full screen.
3. Redo the window to the initial size.

[Expected result]:

There should be no black flicker. 

[Actual result]:

A black flicker appears when you exit from full screen.

Please see the attached video.
Any thoughts on this Markus? Or ideas on who to redirect to?
Flags: needinfo?(mstange)
I did see some flicker on my OSX machine, but it's not always happened.

Reporter, could you help to disable "layers.async-pan-zoom.enabled" to reproduce again?
If you go to a page without scroll bar(like google.com), does it still happen?
Flags: needinfo?(ovidiu.boca)
(Reporter)

Comment 3

a year ago
Hi Peter,

I tried to reproduce this with the latest Nightly 57.0a1(2017-09-07) but I can't. The black flicker doesn't occur anymore.

 (In reply to Peter Chang[:pchang] from comment #2)
> I did see some flicker on my OSX machine, but it's not always happened.
Did you test with the latest Nightly build?
Flags: needinfo?(ovidiu.boca)
(In reply to ovidiu boca[:Ovidiu] from comment #3)
> Hi Peter,
> 
> I tried to reproduce this with the latest Nightly 57.0a1(2017-09-07) but I
> can't. The black flicker doesn't occur anymore.
> 
>  (In reply to Peter Chang[:pchang] from comment #2)
> > I did see some flicker on my OSX machine, but it's not always happened.
> Did you test with the latest Nightly build?

Yes, but I'm not sure the flicker is the same as yours because I can't always reproduce it.


Name 	Firefox
Version 	57.0a1
Build ID 	20170907220212
Update History 	
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
OS 	Darwin 16.7.0
Can you find a regression range and a fix range? It's possible that bug 1394654 fixed this.
Flags: needinfo?(mstange) → needinfo?(ovidiu.boca)

Updated

a year ago
Whiteboard: gfx-noted
(Reporter)

Comment 6

a year ago
I tried to use mozregression to find the fix but I couldn't reproduce this issue anymore.
Flags: needinfo?(ovidiu.boca)
Let's reopen if it comes back.
Status: NEW → RESOLVED
Last Resolved: a year ago
Priority: -- → P3
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.