Incorrect sample for Using the span keyword in Line-based placement with CSS Grid docs

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: joseantonio.blanco, Assigned: cmills)

Tracking

Details

(URL)

(Reporter)

Description

a year ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

In the "Using the span keyword" section, the last paragraphs explain the span syntax when using grid-row-start/end and grid-column-start/end, but the examples are not correct.

The first example, that reads:

.box1 {
    grid-column-start: 1;
    grid-row-start: 1 /  span 3;
}

should be either:

.box1 {
    grid-column-start: 1;
    grid-row: 1 /  span 3;
}

or: 

.box1 {
    grid-column-start: 1;
    grid-row-start: 1;
    grid-row-end: span 3;
}

Similar correction applies to the second example.
Hopefully this means that I've properly understood the spec :)
Thanks.
Hi there Jose,

You are absolutely correct that this was wrong. The examples were trying to apply grid-row shorthand values to the grid-row-start longhand property!

I've updated them to something that I think makes a lot more sense. Do you think this is OK? 

Thanks for reporting this!
Assignee: nobody → cmills
(Reporter)

Comment 2

a year ago
Hi Cris,

Perfect, now both variations of the syntax are properly explained. Thanks for fixing this, and congrats on the docs. If I was able to detect the error, is because the MDN documentation helped me a lot to understand the grid spec.
Thanks!
Cool, I'm so glad you like the docs! Thanks again.

Closing this one now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.