Tour overlay may be accidentally dismissed if visiting some of the sections

RESOLVED DUPLICATE of bug 1374544

Status

()

Firefox
New Tab Page
RESOLVED DUPLICATE of bug 1374544
3 months ago
3 months ago

People

(Reporter: petruta, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 affected, firefox57 affected)

Details

(Reporter)

Description

3 months ago
[Affected versions]:
- Firefox 56.0 beta 8 
- Nightly 57.0a1 - for Sync section

[Affected platforms]:
- Win 7 32-bit
- Ubuntu 16.04 32-bit
- Mac OS X 10.9.5

[Steps to reproduce]:
1. Open a new tab and select FoxHead icon to start the tour
2. Click on Add-ons section and then "Show Add-ons in Menu" button
3. Menu Panel opens with Add-ons icon highlighted - Click on the icon
4. Return to tour and go to Sync section
5. Enter an e-mail address and click Next

[Expected result]:
3. about:addons is opened in a new tab and the user can continue the tour
5. Create Account opens in a new tab

[Actual result]:
3. about:addons opens in the same tab. Back button is disabled.
5. Create Account opens in the same tab. Back button is disabled.

[Regression range]:
- Not a regression, it also reproduces on Nightly 56.0a1 2017-06-20.

Updated

3 months ago
Whiteboard: [photon-onboarding][triage]

Comment 1

3 months ago
its by design, Wont fix
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
Whiteboard: [photon-onboarding][triage]
(In reply to Francis Lee [:frlee] from comment #1)
> its by design, Wont fix

I understand that the following behaviour is expected: click the "Show Add-ons in Menu" button -> about:addons opens in the same tab. 
What is unclear is the fact that in a private window the behaviour is different: about:addons opens in a new tab.  Is this expected, too or a new bug must be filled?
Flags: needinfo?(gasolin)
Flags: needinfo?(frlee)

Comment 3

3 months ago
the rationale is described in bug 1374544
Flags: needinfo?(gasolin)
Flags: needinfo?(frlee)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1374544
You need to log in before you can comment on or make changes to this bug.