Closed Bug 1396028 Opened 6 years ago Closed 5 years ago

Enable autoscrolling in Print Preview

Categories

(Core :: Print Preview, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 239213
Tracking Status
firefox57 --- wontfix

People

(Reporter: botond, Unassigned)

References

Details

Autoscrolling has been broken in Print Preview for a while. I posted a patch to disable it in bug 1393424. I'm filing this bug to track re-enabling it.

At least two things need to happen before we can re-enable it:

  1) The content-side JS code that initiates autoscrolling uses
     "content.performance.now()" to obtain a timestamp [1], but
     "content.performance" is null in Print Preview. We'll need
     to find another way of getting a timestamp.

  2) There is a coordinate systems problem, tracked in bug 1393424,
     which causes both tooltips and the autoscroll anchor to appear 
     in the wrong location. In the case of autoscrolling, this
     causes unintended scrolling, since scrolling is caused by
     the mouse being away from the autoscroll anchor.

[1] http://searchfox.org/mozilla-central/rev/51b3d67a5ec1758bd2fe7d7b6e75ad6b6b5da223/toolkit/content/browser-content.js#179
Priority: -- → P3
Botond, can you copy comment 0 to bug 239213?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Flags: needinfo?(botond)
(In reply to Jonathan Watt [:jwatt] (needinfo? me) from comment #1)
> Botond, can you copy comment 0 to bug 239213?

Done (bug 239213 comment 7).
Flags: needinfo?(botond)
You need to log in before you can comment on or make changes to this bug.