Middle-clicking in Print Preview opens links from underlying page

RESOLVED DUPLICATE of bug 127909

Status

()

P3
normal
RESOLVED DUPLICATE of bug 127909
a year ago
10 months ago

People

(Reporter: botond, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

(Reporter)

Description

a year ago
STR:
  1. Load https://en.wikipedia.org/wiki/Main_Page
     (chosen because it has a lot of links)
  2. Enter Print Preview mode
  3. Middle-click around on the Print Preview page several times
     in different locations.
  4. Close Print Preview mode

Expected results:

  Since there are no links shown in Print Preview mode, no new
  tabs have been opened as a result of the middle-clicking.

Actual results:

  Some of the middle-clicks caused new tabs to open. It appears
  as if the middle-clicks go through to the real page which is
  "under" the Print Preview page, and are handled there.
Priority: -- → P3
status-firefox57: affected → wontfix

Comment 1

10 months ago
Botond, isn't this due to the links still being active in the print preview document to a certain extent? I.e. bug 127909? Print preview is implemented by opening a new tab and then hiding all the normal browser UI, so there shouldn't be an "original document underneath".
Flags: needinfo?(botond)
(Reporter)

Comment 2

10 months ago
You're right, on closer inspection the opened links correspond to the text that was clicked on the preview page itself, not the corresponding position on the original page. I guess that makes this a duplicate of bug 127909.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 127909
You need to log in before you can comment on or make changes to this bug.