[FIX] Bookmarks window doesn't need to tell me I'm "default"

RESOLVED FIXED in mozilla1.0

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Ken Harris, Assigned: Pierre Chanial)

Tracking

({polish})

Trunk
mozilla1.0
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

3.42 KB, patch
Biesinger
: review+
Ben Goodger (use ben at mozilla dot org for email)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020422
BuildID:    2002042203

The title of the bookmarks window is "Bookmarks for default".
Every user will have his own "default" profile, and rarely any
other, so there's no reason to tell me these are bookmarks
"for default".

Reproducible: Always
Steps to Reproduce:
1. Start Mozilla
2. Choose Bookmarks -> Manage Bookmarks...

Actual Results:  The window title is "Bookmarks for default".

Expected Results:  The title chould just be "Bookmarks".

If there are multiple profiles, you could then add "... for XYZ".
If there is exactly one profile named "default", though, it
seems silly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

16 years ago
taking, patch will follow
Assignee: ben → pierrechanial
Keywords: polish
OS: MacOS X → All
Hardware: Macintosh → All
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

16 years ago
Created attachment 81504 [details] [diff] [review]
patch v1.0

While at was around, I've done a bit of clean-up.
Please, r=, sr=
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: patch, review
Summary: Bookmarks window doesn't need to tell me I'm "default" → [FIX] Bookmarks window doesn't need to tell me I'm "default"
(Assignee)

Comment 3

16 years ago
Created attachment 81672 [details] [diff] [review]
patch v1.1

Use of const instead of var per biesi request
(Assignee)

Updated

16 years ago
Attachment #81504 - Attachment is obsolete: true
Comment on attachment 81672 [details] [diff] [review]
patch v1.1

r=biesi
Attachment #81672 - Flags: review+
What if the single profile isn't called default? (i.e. I've removed all my 
profiles but "Ben Goodger")

Can't you check for the string that's used by the profile code as the default 
name instead?
(Assignee)

Comment 6

16 years ago
Created attachment 84300 [details] [diff] [review]
Patch v1.2

Ben, sure.
ccarlen confirmed me that the default profile name is not localizable.
On windows, it's 'Default' and on the others: 'default'.
I also change the dtd.
With this patch, the title of the bookmark manager is 'Bookmark Manager' if and
only if there is one profile named 'default' in low case.
Attachment #81672 - Attachment is obsolete: true
(Assignee)

Comment 7

16 years ago
Ben, feel free to check in the dtd change or not.
Comment on attachment 84300 [details] [diff] [review]
Patch v1.2

you could do the |windowNode.setAttribute("title", titleString);| after the if

r=biesi
Attachment #84300 - Flags: review+
(Assignee)

Comment 9

16 years ago
Biesi: I can not do that since I do not modify the bookmark manager title in one
case (#profile=1 and profile name != default).
Comment on attachment 84300 [details] [diff] [review]
Patch v1.2

sr=ben@netscape.com
Attachment #84300 - Flags: superreview+
(Assignee)

Comment 11

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.