--disable-optimize should enable incremental linking

RESOLVED DUPLICATE of bug 1341504

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1341504
11 months ago
5 months ago

People

(Reporter: jya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
Currently you can build with either --enable-debug, which enables debugging symbols but also enables all the assertions in the code.

The issue with such built is that it's barely usable on all but the most powerful machines.

It would be great to have a --disable-debug-assertions that works in combination with --enable-debug , which would disable all assertions.
Making a much more usable build.

The advantage of using --enable-debug also turn on features that greatly speed up compilation time, such as incremental linking.

Comment 1

11 months ago
What is even the point of --enable-debug if you can turn off the assertions?  You might as well just use an opt build at that point.  And if things like incremental linking don't work with opt, we should make them work.
(Reporter)

Comment 2

11 months ago
you're right.

On windows, as per bug 1341504, incremental linking in effect is only enabled on debug build.
On a very fast dell xps 159560 laptop, any relink of XUL takes over 3 minutes, as opposed to a debug build where it will take only 6s.

Adding export LDFLAGS="-OPT:NOREF -OPT:NOICF" unfortunately to mozconfig unfortunately doesn't have the intended effect.

I'm guessing, that a work around would be to compile with those flags when --disable-optimize is set.
OS: Unspecified → Windows
See Also: → bug 1341504
Summary: Add a --disable-debug-assertions parameters → --disable-optimize should enable incremental linking
(Reporter)

Comment 3

11 months ago
Actually fixing bug 1341504 will accomplish what's described here, so let's make it a dupe.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341504

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.