Fix the beetmover-repackage regression caused by bug 1390461

REOPENED
Assigned to

Status

defect
REOPENED
2 years ago
Last year

People

(Reporter: zbraniecki, Assigned: zbraniecki)

Tracking

unspecified

Firefox Tracking Flags

(firefox57 affected)

Details

Attachments

(3 attachments)

As part of bug 1390461 we extended l10n-check test to clobber the things it tested at the end.

It seems that in result of that, we started clobbering the langpack that is needed later for the beetmover-repackage (see bug 1390461 comment 49 for details).
Comment hidden (mozreview-request)
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
This is a trivial fix that reverts the removal of the generated langpack.

Aki, is it possible for you to check if this will fix the beetmover-repackage jobs?

I can't see any other things that would cause it, but I'm also confused because l10n-check was meant to only generate x-test langpacks, so it should also clean up only x-test langpacks. On the other hand, while going through a plethora of platform issues with that patch I'm pretty sure I saw an attempt in l10n-check to test `langpack.target.xpi` which makes it more probable that this patch will fix things, despite it not being supposed to cause the breakage.

Anyhoo, if it does fix things, I'd like to land it ASAP, as I don't believe we need any deeper review process, and we can discuss further improvements to the test next week.


Also, NI on Pike to make put it on his radar.
Flags: needinfo?(l10n)
Flags: needinfo?(aki)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8903873 [details]
Bug 1396177 - Do not clobber the langpack in l10n-check.

https://reviewboard.mozilla.org/r/175638/#review180692

I think this could work. Might take me a few hours to test... we may want to just try it.
Attachment #8903873 - Flags: review?(aki) → review+

Comment 4

2 years ago
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b01a7e57425b
Do not clobber the langpack in l10n-check. r=aki

Comment 5

2 years ago
https://tools.taskcluster.net/groups/SfTGmPZFTFSUTKXLjswtHg is a linux nightly graph off a test push on the `date` project branch.
https://hg.mozilla.org/mozilla-central/rev/b01a7e57425b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
(In reply to Aki Sasaki [:aki] from comment #5)
> https://tools.taskcluster.net/groups/SfTGmPZFTFSUTKXLjswtHg is a linux
> nightly graph off a test push on the `date` project branch.

It seems that the two jobs that were failing got completed here. Can you confirm that this is fixed now?

Comment 8

2 years ago
Looks like this fixes the problem. Thanks!
Flags: needinfo?(aki)
Thank you!

Pike - do you want me to file a follow-up to figure out how to remove the langpack in clobber without removing the langpack that the beetmover needs, or are you ok with the current status?
OHOH. OHOHOH. Did I say OH?

This means that we're uploading the web-extension variant of the langpack, and inspecting the target.langpack.xpi from the latest nightlies confirms that.

We'll need a real fix. MOZ_SIMPLE_PACKAGE_NAME= might need to move around a bit. Gonna try that.
Status: RESOLVED → REOPENED
Flags: needinfo?(l10n)
Resolution: FIXED → ---
(In reply to Axel Hecht [:Pike] from comment #11)
> I pushed something completely untested to
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=1e29dab9647b9de9b624626425b8bae304aa0156

That broke, but https://treeherder.mozilla.org/#/jobs?repo=try&revision=295616f4fb1ef5e9aa72c51390f5d5668eacd4d7&selectedJob=128291450 looks green.
Trying in https://tools.taskcluster.net/groups/O5UqTdV8Q6yxNMIQnnB-Og . BM-R is what broke last time. I backed out Zibi's patch and landed yours on date-branch; hopefully this works!

Comment 16

2 years ago
mozreview-review
Comment on attachment 8904285 [details]
bug 1396177, unset MOZ_SIMPLE_PACKAGE_NAME for all of l10n-check,

https://reviewboard.mozilla.org/r/176064/#review181086

Looks like this works!
Attachment #8904285 - Flags: review?(aki) → review+

Comment 17

2 years ago
mozreview-review
Comment on attachment 8904284 [details]
Backed out changeset b01a7e57425b (bug 1396177) as we're uploading the wrong file to ftp

https://reviewboard.mozilla.org/r/176062/#review181098
Attachment #8904284 - Flags: review+

Comment 18

2 years ago
Pushed by axel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6211693ad32c
Backed out changeset b01a7e57425b as we're uploading the wrong file to ftp r=aki
https://hg.mozilla.org/integration/autoland/rev/d3021ff5ea6a
unset MOZ_SIMPLE_PACKAGE_NAME for all of l10n-check, r=aki
https://hg.mozilla.org/mozilla-central/rev/d3021ff5ea6a
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED

Comment 20

2 years ago
backoutbugherder
Backed out for breaking Beta release automation per bug 1385227.
https://hg.mozilla.org/mozilla-central/rev/889b7cf3a773
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla57 → ---

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.