crashed tab exclamation icon overlaps text in the tab

VERIFIED FIXED in Firefox 57

Status

()

P1
trivial
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ddurst, Assigned: dao)

Tracking

({regression})

57 Branch
Firefox 57
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ verified)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Had some crashy tabs (all amazon.com page loads) in Nightly this evening, and noticed the tab looked wonky when the "Gah. Your tab crashed" screen was displayed.

I'm using Dark theme, Compact on OSX. Haven't looked at default theme.

Comment 1

2 years ago
Looks like it might have been caused by bug 1352119 like bug 1392622 and bug 1392792. Are you sure you're up-to-date?
Flags: needinfo?(ddurst)
Whiteboard: [photon-animation][triage]
(Reporter)

Comment 2

2 years ago
I'll check tonight, assuming I can crash a tab. I have an update pending so I'll try before and after update and post back build IDs here.
Flags: needinfo?(ddurst)

Comment 3

2 years ago
(In reply to David Durst [:ddurst] from comment #2)
> I'll check tonight, assuming I can crash a tab. I have an update pending so
> I'll try before and after update and post back build IDs here.

If you hover over a tab it tells you the child pid, so then you can just kill that with a unix command and/or using task manager or whatever. :-)
(Reporter)

Comment 4

2 years ago
Attachment #8903872 - Attachment is obsolete: true
(Reporter)

Comment 6

2 years ago
Attached screenshots from before updating to current and after. To make sure it wasn't due to reduced tab width, I also checked it in a window with only two tabs open.
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
[Tracking Requested - why for this release]: user visible regression for the tab-crashed icon

Using mozregression I confirmed that this was broken by bug 1388509.

Based on the commit message in that patch, that patch should have only affected pinned tabs. The tab-crashed icon is placed correctly in pinned tabs, but shows up in the wrong place for non-pinned tabs now. Dao, can you take a look at this?
status-firefox56: --- → unaffected
tracking-firefox57: --- → ?
Flags: needinfo?(dao+bmo)
OS: Mac OS X → All
Whiteboard: [reserve-photon-animation] → [photon-visual][triage]
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(dao+bmo)
Priority: P3 → P1
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Iteration: --- → 57.3 - Sep 19
QA Contact: ovidiu.boca

Comment 10

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e40392db1f5
Fix tab-icon-overlay's position in non-pinned tabs. r=jaws
https://hg.mozilla.org/mozilla-central/rev/4e40392db1f5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
tracking-firefox57: ? → +

Comment 12

2 years ago
I have verified this on Mac OS X 10.12.5 and Windows 10 x 64 with FF Nightly 57.0a1(2017-09-19) and i can confirm the fix. Now, in case of a tab crash, the exclamation icon does not overlaps the text in the tab(for non pinned tabs). Thank you
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.