Frequent Win7-only test_accessiblecaret_selection_mode.py AccessibleCaretSelectionModeTestCase.test_long_press_to_select_when_partial_visible_word_is_selected | AssertionError: 'aaaaaaaa' != u'' when Gecko 57 merges to Beta on 2017-09-14

VERIFIED DUPLICATE of bug 1399204

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 1399204
2 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Trunk
Unspecified
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57+ disabled)

Details

Reporter

Description

2 years ago
[Tracking Requested - why for this release]: Frequent test failure on the next merge day.

https://treeherder.mozilla.org/logviewer.html#?job_id=127931611&repo=try

TEST-UNEXPECTED-FAIL | test_accessiblecaret_selection_mode.py AccessibleCaretSelectionModeTestCase.test_long_press_to_select_when_partial_visible_word_is_selected | AssertionError: 'aaaaaaaa' != u''

I haven't had a chance to bisect this yet, but it started in the last couple days and is on Win7 only.

To reproduce the build configuration in question, the patches below should suffice.
https://hg.mozilla.org/try/rev/70cb6436d870bc25344b98e8ec3ed1be9cf9afc6
https://hg.mozilla.org/try/rev/30a74bd46d8aa778a3ab706c4c77b567e5355a6d
Reporter

Comment 1

2 years ago
Try bisection confirms this was caused by bug 1394881. Failure rate is ~20% on opt builds.
Blocks: 1394881
Flags: needinfo?(ato)
Summary: test_accessiblecaret_selection_mode.py is going to fail frequently on Windows 7 when Gecko 57 merges to Beta on 2017-09-20 → Frequent Win7-only test_accessiblecaret_selection_mode.py AccessibleCaretSelectionModeTestCase.test_long_press_to_select_when_partial_visible_word_is_selected | AssertionError: 'aaaaaaaa' != u'' when Gecko 57 merges to Beta on 2017-09-20
Comment hidden (Intermittent Failures Robot)
Reporter

Comment 3

2 years ago
I've verified on m-c tip that this is still happening around the same frequency. Note that per Sylvestre's email today, the date of the 57 merge to Beta is now a week from today (14-Sep) rather than the 20th as was previously the case.
Summary: Frequent Win7-only test_accessiblecaret_selection_mode.py AccessibleCaretSelectionModeTestCase.test_long_press_to_select_when_partial_visible_word_is_selected | AssertionError: 'aaaaaaaa' != u'' when Gecko 57 merges to Beta on 2017-09-20 → Frequent Win7-only test_accessiblecaret_selection_mode.py AccessibleCaretSelectionModeTestCase.test_long_press_to_select_when_partial_visible_word_is_selected | AssertionError: 'aaaaaaaa' != u'' when Gecko 57 merges to Beta on 2017-09-14
Comment hidden (Intermittent Failures Robot)
See Also: → 1399204
I’ve not been meaning to ignore this, but it’s unclear to me how
and where to reproduce this.  According to https://bugzil.la/1399204
this is now also hit as an intermittent on trunk (m-i currently,
soon m-c?).  But what is unclear to me is what the two patches
linked to in comment #0 changes Marionette’s behaviour?

How would I proceed in reproducing this reliably on m-c?
Depends on: 1399076
Flags: needinfo?(ato)
Reporter

Comment 6

2 years ago
The patches in #c0 change the Firefox build configuration to mimic how it'll be built once uplifted to Beta. Branding changes, ifdef changes, etc. For whatever reason, those changes combined with bug 1394881 (confirmed with bisection on Try and lots of retriggers) made this test start failing on Win7 around 20% of the time.
Reporter

Comment 7

2 years ago
Also, if you think bug 1399076 may have helped here, I'd be happy to run another Try push and see?
Flags: needinfo?(ato)
Reporter

Comment 8

2 years ago
I did a new round of simulations off m-c tip this morning and verified that it's still affected.
Flags: needinfo?(ato)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Priority: -- → P3
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Reporter

Comment 14

2 years ago
Fixed by bug 1399204.
Status: NEW → RESOLVED
Closed: 2 years ago
No longer depends on: 1399076
Resolution: --- → DUPLICATE
Duplicate of bug: 1399204
Reporter

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.