Closed Bug 1396380 Opened 4 years ago Closed 4 years ago

[Nightly] Requests fail to load.

Categories

(Core :: Networking, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ant.lerner, Assigned: dragana)

Details

Attachments

(1 file)

827.20 KB, text/plain
Details
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170902220453

Steps to reproduce:

I just go to a website (i.e. https://duckduckgo.com, or https://mozilla.org).


Actual results:

The request sometimes fails. I reload and i either have a failed TLS handshake, either another request, either the page loads normally (more frequent, by the way).
(I had no problems with FF 55)
(Kernel: 4.9.0-3-amd64, Debian 9.1)


Expected results:

The page should load normally at first try.
Component: Untriaged → Networking
Product: Firefox → Core
Hi Antoine,
Could you help us to diagnose this by reproducing and gathering some logs?
Instructions here: https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging#Using_aboutnetworking
Flags: needinfo?(ant.lerner)
Attached file Network log
Flags: needinfo?(ant.lerner)
[Tracking Requested - why for this release]:

It is important to figure out why page loads some times fail. This looks like something new that only appeared on Nightly 57.
Assignee: nobody → dd.mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
I just got back from PTO, I will try to get to this today, I have couple of bugs with similar priority. If someone have time please take a look.
Antoine, do you remember which page was failing?

Can you still reproduce with newest Nightly?
Can you try to change pref "network.tcp.tcp_fastopen_enable" and retry (open a new tab and type about:config, then search for network.tcp.tcp_fastopen_enable and change value from true to false or vice versa)?
Flags: needinfo?(ant.lerner)
Hello,

It seems like I don't have this bug anymore.

Antoine.
Flags: needinfo?(ant.lerner)
From the log I only see that some connections are reset by the server. I do not know know why.

On this connection TFO was used, I am not sure if that has an effect. I think not since TFO was on for longer time before this bug is reported.

I will closed this bug as worksforme. We can reopen it if it appears again.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.