Popup about autofilling addresses hides credit card popup

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
a year ago
10 months ago

People

(Reporter: dotn8, Unassigned, NeedInfo)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 unaffected, firefox58 affected)

Details

(Whiteboard: [form autofill])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170902220453

Steps to reproduce:

1. Install Firefox Nightly
2. Go to a web form that asks for an address, then asks for a credit card
3. Fill in the address, click Next, then fill in the credit card info


Actual results:

First there was a popup about saving the credit card. But before I could do anything to it, the popup disappeared and in its place another popup appeared talking about autofilling addresses. When I closed the autofill addresses popup, the original credit card popup was nowhere to be found. I went to Saved Credit Cards and there weren't any.


Expected results:

Once I resolved the autofill popup, the credit card popup should have appeared.
Component: Untriaged → Form Manager
Product: Firefox → Toolkit
Steve, how did we decide to handle this? Is this still a problem?
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
status-firefox-esr52: --- → unaffected
status-thunderbird_esr52: --- → unaffected
Flags: needinfo?(schung)
Priority: -- → P1
Whiteboard: [form autofill:M4]

Comment 2

11 months ago
Since I applied different notification ID for address/creditcard doorhanger, I assume that there should be 2 doorhanger anchor icons besides the address bar and user can trigger the doorhanger again by clicking on the icon. Maybe that's the expected behavior for popupNotification that it only show 1 doorhanger at the time. I'll verify this on the latest build.
Flags: needinfo?(schung)

Comment 3

11 months ago
Created attachment 8908498 [details]
doorhanger_anchor.jpeg

Hi dotn8, could you please help me verify if there are "2" notification icons besides the address bar like the attachment. One is for address and another one is for credit card. You'll need to autofill the data and revise part of the autofilled fields to make sure the doorhanger displayed(If you submitted an autofilled form without any changes, there will be no doorhanger popped up). Please also provide your shopping website because we want to know if there's any problem encountered by other issue, thanks.
Flags: needinfo?(dotn8)
status-firefox57: affected → unaffected
status-firefox58: --- → affected
The current behavior is just like comment 3 so close this bug as WORKSFORME by now. Feel free to reopen it if there are still issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
Whiteboard: [form autofill:M4] → [form autofill]
You need to log in before you can comment on or make changes to this bug.