WebExtensions popup not focused and input events not fired

RESOLVED DUPLICATE of bug 1324255

Status

RESOLVED DUPLICATE of bug 1324255
a year ago
6 months ago

People

(Reporter: dw-dev, Unassigned)

Tracking

55 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170809080026

Steps to reproduce:

Tested with my Search Site WE add-on.  Tested on Firefox 55, 56 and 57.

1) Clicked on toolbar button to show popup. 

2) Typed text into popup <input type="text"> element and then typed Enter.




Actual results:

Firefox 55:

1) Popup was focused.  And popup <input type="text"> element was focused.

2) 'keypress' event was fired for <input type=text> element when Enter was typed..

Firefox 56 & 57:

1) Popup was NOT focused.  And <input type="text"> element was NOT focused.

2) 'keypress' event was NOT fired for <input type=text> element when Enter was typed.




Expected results:

Firefox 56 & 57:

1) Popup should be focused.  And <input type="text"> element should be focused.

2) 'keypress' event should be fired for <input type=text> element when Enter was typed.
Component: Untriaged → WebExtensions: Frontend
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324255

Updated

6 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.