Intermittent toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | xpcshell return code: 139

RESOLVED DUPLICATE of bug 1399773

Status

()

Toolkit
Application Update
P5
normal
RESOLVED DUPLICATE of bug 1399773
2 months ago
a month ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=128090179&repo=autoland

https://queue.taskcluster.net/v1/task/ScBj-FxXTeyQbmLmaamBzg/runs/0/artifacts/public/logs/live_backing.log

[task 2017-09-03T10:06:58.654541Z] 10:06:58     INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | test_custom - [test_custom : 341] the url query string for %CUSTOM% should equal the expected value - "custom" == "custom"
[task 2017-09-03T10:06:58.654744Z] 10:06:58     INFO -  (xpcshell/head.js) | test run_next_test 12 pending (2)
[task 2017-09-03T10:06:58.654973Z] 10:06:58     INFO -  (xpcshell/head.js) | test test_custom finished (2)
[task 2017-09-03T10:06:58.655258Z] 10:06:58     INFO -  toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | Starting test_systemCapabilities
[task 2017-09-03T10:06:58.655511Z] 10:06:58     INFO -  (xpcshell/head.js) | test test_systemCapabilities pending (2)
[task 2017-09-03T10:06:58.655749Z] 10:06:58     INFO -  (xpcshell/head.js) | test run_next_test 12 finished (2)
[task 2017-09-03T10:06:58.656107Z] 10:06:58     INFO -  TEST-PASS | toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | test_systemCapabilities - [test_systemCapabilities : 349] the url param for %SYSTEM_CAPABILITIES% should equal the expected value - "ISET:NA,MEM:882" == "ISET:NA,MEM:882"
[task 2017-09-03T10:06:58.656308Z] 10:06:58     INFO -  (xpcshell/head.js) | test run_next_test 13 pending (2)
[task 2017-09-03T10:06:58.656546Z] 10:06:58     INFO -  (xpcshell/head.js) | test test_systemCapabilities finished (2)
[task 2017-09-03T10:06:58.656778Z] 10:06:58     INFO -  (xpcshell/head.js) | test run_next_test 13 finished (1)
[task 2017-09-03T10:06:58.656992Z] 10:06:58     INFO -  exiting test
[task 2017-09-03T10:06:58.657296Z] 10:06:58     INFO -  toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | Segmentation fault
[task 2017-09-03T10:06:58.657530Z] 10:06:58     INFO -  toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | 13
[task 2017-09-03T10:06:58.657741Z] 10:06:58     INFO -  <<<<<<<
[task 2017-09-03T10:06:59.092751Z] 10:06:59     INFO -  mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/arO25QgZTBaZvfq9YsBzGw/artifacts/public/build/target.crashreporter-symbols.zip
[task 2017-09-03T10:07:03.264607Z] 10:07:03     INFO -  mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpHU0dSq/491f617e-93c7-c3cf-853b-ce0669e5ed7f.dmp /tmp/tmpDYd4Ff
[task 2017-09-03T10:07:03.324180Z] 10:07:03     INFO -  mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/491f617e-93c7-c3cf-853b-ce0669e5ed7f.dmp
[task 2017-09-03T10:07:03.324595Z] 10:07:03     INFO -  mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/491f617e-93c7-c3cf-853b-ce0669e5ed7f.extra
[task 2017-09-03T10:07:03.327442Z] 10:07:03  WARNING -  PROCESS-CRASH | toolkit/modules/tests/xpcshell/test_UpdateUtils_url.js | application crashed [@ libxul.so + 0x5fa757]
[task 2017-09-03T10:07:03.327522Z] 10:07:03     INFO -  Crash dump filename: /tmp/tmpHU0dSq/491f617e-93c7-c3cf-853b-ce0669e5ed7f.dmp
[task 2017-09-03T10:07:03.327572Z] 10:07:03     INFO -  Operating system: Android
[task 2017-09-03T10:07:03.327643Z] 10:07:03     INFO -                    0.0.0 Linux 2.6.29 #1 PREEMPT Thu Nov 7 22:27:50 UTC 2013 i686
[task 2017-09-03T10:07:03.327690Z] 10:07:03     INFO -  CPU: x86
[task 2017-09-03T10:07:03.327748Z] 10:07:03     INFO -       GenuineIntel family 6 model 3 stepping 3
[task 2017-09-03T10:07:03.331396Z] 10:07:03     INFO -       1 CPU
[task 2017-09-03T10:07:03.331777Z] 10:07:03     INFO -  GPU: UNKNOWN
[task 2017-09-03T10:07:03.331858Z] 10:07:03     INFO -  Crash reason:  SIGSEGV
[task 2017-09-03T10:07:03.331904Z] 10:07:03     INFO -  Crash address: 0x138
[task 2017-09-03T10:07:03.332240Z] 10:07:03     INFO -  Process uptime: not available
[task 2017-09-03T10:07:03.332749Z] 10:07:03     INFO -  Thread 2 (crashed)
[task 2017-09-03T10:07:03.333267Z] 10:07:03     INFO -   0  libxul.so + 0x5fa757
[task 2017-09-03T10:07:03.333376Z] 10:07:03     INFO -      eip = 0xb3aa2757   esp = 0xaf2ffe10   ebp = 0xaf2ffe48   ebx = 0xb7ca2eac
[task 2017-09-03T10:07:03.333444Z] 10:07:03     INFO -      esi = 0xaf53fdc0   edi = 0xaf53fdc8   eax = 0x2752a417   ecx = 0xaf53fdd4
[task 2017-09-03T10:07:03.333732Z] 10:07:03     INFO -      edx = 0x00055846   efl = 0x00000202
[task 2017-09-03T10:07:03.333794Z] 10:07:03     INFO -      Found by: given as instruction pointer in context
[task 2017-09-03T10:07:03.333836Z] 10:07:03     INFO -   1  libnss3.so + 0x8f9cb
[task 2017-09-03T10:07:03.333887Z] 10:07:03     INFO -      eip = 0xb7f8b9cb   esp = 0xaf2ffe50   ebp = 0xaf2ffe98
[task 2017-09-03T10:07:03.334173Z] 10:07:03     INFO -      Found by: previous frame's frame pointer
[task 2017-09-03T10:07:03.334644Z] 10:07:03     INFO -   2  libc.so + 0xf274
[task 2017-09-03T10:07:03.334740Z] 10:07:03     INFO -      eip = 0xb7d64274   esp = 0xaf2ffea0   ebp = 0x00000000
[task 2017-09-03T10:07:03.334791Z] 10:07:03     INFO -      Found by: previous frame's frame pointer
[task 2017-09-03T10:07:03.334833Z] 10:07:03     INFO -   3  libnss3.so + 0x8f8ad
[task 2017-09-03T10:07:03.335378Z] 10:07:03     INFO -      eip = 0xb7f8b8ad   esp = 0xaf2ffec4   ebp = 0x00000000
[task 2017-09-03T10:07:03.335434Z] 10:07:03     INFO -      Found by: stack scanning
[task 2017-09-03T10:07:03.335474Z] 10:07:03     INFO -   4  libc.so + 0xf179
[task 2017-09-03T10:07:03.335527Z] 10:07:03     INFO -      eip = 0xb7d64179   esp = 0xaf2ffedc   ebp = 0x00000000
[task 2017-09-03T10:07:03.335571Z] 10:07:03     INFO -      Found by: stack scanning
[task 2017-09-03T10:07:03.335615Z] 10:07:03     INFO -   5  libc.so + 0x26975
[task 2017-09-03T10:07:03.335912Z] 10:07:03     INFO -      eip = 0xb7d7b975   esp = 0xaf2ffef0   ebp = 0x00000000
[task 2017-09-03T10:07:03.335965Z] 10:07:03     INFO -      Found by: stack scanning
[task 2017-09-03T10:07:03.336012Z] 10:07:03     INFO -   6  libnss3.so + 0x8f8ad
[task 2017-09-03T10:07:03.336320Z] 10:07:03     INFO -      eip = 0xb7f8b8ad   esp = 0xaf2ffef4   ebp = 0x00000000
[task 2017-09-03T10:07:03.336722Z] 10:07:03     INFO -      Found by: stack scanning

Comment 1

2 months ago
1 failures in 939 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-2-x86: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1396390&startday=2017-08-28&endday=2017-09-03&tree=all
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399773
You need to log in before you can comment on or make changes to this bug.