`ondragend` event on anchor reports nonsense x and y coordinates

RESOLVED DUPLICATE of bug 505521

Status

()

defect
RESOLVED DUPLICATE of bug 505521
2 years ago
2 years ago

People

(Reporter: roderic.day, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170902100317

Steps to reproduce:

Using this HTML file:

```
<body></body>
<script>
anchor = document.createElement("a");
anchor.textContent = "hey";
anchor.href = "#";
anchor.ondragend = function(e){console.log(e)};
document.body.appendChild(anchor);
</script>
```

Simply drag the anchor on-screen, and watch the console.


Actual results:

On Firefox, the event always returns

`dragend { target: a, buttons: 0, clientX: 0, clientY: 0, layerX: 17895698, layerY: 17895698 }`


Expected results:

On Safari and Chrome, the event returns something like

`DragEvent {isTrusted: true, dataTransfer: DataTransfer, screenX: 149, screenY: 279, clientX: 81, …}`
Component: Untriaged → Drag and Drop
Product: Firefox → Core

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505521
You need to log in before you can comment on or make changes to this bug.