Closed Bug 1396491 Opened 2 years ago Closed 2 years ago

Enable doubled border support for wr in gecko side

Categories

(Core :: Graphics: WebRender, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: kechen, Assigned: kechen)

References

(Depends on 1 open bug)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(1 file)

Styled border is not fully supported by WebRender(especially in dotted-style), some reftests might fail due to this change[1];
 however, per discuss with Ethan, we think it might be advisable to enable it and fuzzy the reftests in current stage.

Jeff, do you have any thoughts on this?

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=7434cc37510e215fadfdf2ff80606ad1d380113f&selectedJob=128244419
Flags: needinfo?(jmuizelaar)
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
Comment on attachment 8904451 [details]
Bug 1396491 - Remove the styled border skipped condition;

https://reviewboard.mozilla.org/r/176308/#review183852

::: layout/reftests/border-dotted/reftest.list:5
(Diff revision 1)
>  # Composing dotted/dashed border rendering and not-filled or not-unfilled mask
>  # matches to full-filled box, using fuzzyy because of anti-aliasing.
>  # These check filled and unfilled regions with solid opaque color,
>  # so difference less than 80 is ignorable.
> -fuzzy(80,1500) == border-dotted-interaction.html masked.html
> +fails-if(webrender) fuzzy(80,1500) == border-dotted-interaction.html masked.html

I'm ok with taking the failing. But please file a blocking bug and add a note to reftest.list with the bug number.

::: layout/reftests/w3c-css/submitted/flexbox/reftest.list:149
(Diff revision 1)
>  == flexbox-mbp-horiz-003.xhtml             flexbox-mbp-horiz-003-ref.xhtml
>  == flexbox-mbp-horiz-003-reverse.xhtml     flexbox-mbp-horiz-003-reverse-ref.xhtml
>  == flexbox-mbp-horiz-004.xhtml             flexbox-mbp-horiz-004-ref.xhtml
>  
>  # Tests for min-height:auto / min-width:auto on flex items
> -== flexbox-min-height-auto-001.html flexbox-min-height-auto-001-ref.html
> +fuzzy-if(37-37,46-46) == flexbox-min-height-auto-001.html flexbox-min-height-auto-001-ref.html

Shouldn't these be fuzzy-if(webrender)?
Attachment #8904451 - Flags: review?(jmuizelaar) → review+
Assignee: nobody → kechen
Status: NEW → ASSIGNED
Priority: P2 → P1
Target Milestone: --- → mozilla57
Summary: Support styled border in wr → Enable styled border support for wr in gecko side
Depends on: 1399485
The patch caused several failures in crashtrest with WR build[1], but the failed tests have nothing to do with styled border.
Trying to find the root cause now.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=20f54a79a2783b4642872772b4fa577c39906047&selectedJob=131191872
Flags: needinfo?(jmuizelaar)
There are still some failures in crashtest with this patch[1]. Most of them are caused by the timeout when waiting for the removal of "reftest-wait".
I don't find any styled border in these test case and these failures cannot be reproduced on my machine.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=9cb4ecee842b5b9d0948f0d89cd5b72be52573fd
Per discuss with Ethan, it might be advisable to enable doubled style border first and fix the crashtest failure problem in comment 8 in other bug[1]. 

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1409243
Keywords: checkin-needed
See Also: → 1409243
Summary: Enable styled border support for wr in gecko side → Enable doubled border support for wr in gecko side
Target Milestone: mozilla57 → ---
Autoland can't push this until all pending issues in MozReview are marked as resolved.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/27029757c81b
Remove the styled border skipped condition; r=jrmuizel
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/27029757c81b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.