crash in nsAddrDatabase::NotifyCardEntryChange()

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: endico, Assigned: sspitzer)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I've crashed three times recently in the same spot. For the most recent
crash, I had recently deleted some address cards, shut down the address book
and went on to do other stuff. A few minutes later I crashed. I think that 
was true of the second crash as well. I don't remember about the third.


Incident ID 5542878 and 
Stack Signature  nsAddrDatabase::NotifyCardEntryChange() 2c291992
Email Address endico@mozilla.org
Product ID Mozilla1.0
Build ID 2002042208
Trigger Time 2002-04-23 20:45:36
Platform LinuxIntel
Operating System Linux 2.4.7-10
Module libaddrbook.so
URL visited
User Comments switched from folder back to inbox and scrolled in thread pane
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Source File Name
Trigger Line No.
Stack Trace
nsAddrDatabase::NotifyCardEntryChange()
nsAddrDatabase::DeleteCard()
nsAbAddressCollecter::CollectAddress()
nsAbAddressCollecter::CollectUnicodeAddress()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Execute()
JS_EvaluateUCScriptForPrincipals()
nsJSContext::EvaluateString()
GlobalWindowImpl::RunTimeout()
GlobalWindowImpl::TimerCallback()
nsTimerImpl::Process()
handleMyEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xff9e (0x40393f9e)
libglib-1.2.so.0 + 0x11773 (0x40395773)
libglib-1.2.so.0 + 0x11d39 (0x40395d39)
libglib-1.2.so.0 + 0x11eec (0x40395eec)
libgtk-1.2.so.0 + 0x94333 (0x402b1333)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1c507 (0x404dc507)


Incident ID 5490106
Stack Signature nsAddrDatabase::NotifyCardEntryChange() 2c291992
Email Address endico@mozilla.org
Product ID Mozilla1.0
Build ID 2002041809
Trigger Time 2002-04-22 13:32:04
Platform LinuxIntel
Operating System Linux 2.4.7-10
Module libaddrbook.so
URL visited
User Comments i was playing with dom inspector sidebar tab and then switched to
mail, selected a message and a while later mozilla crashed.
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Source File Name
Trigger Line No.
Stack Trace
nsAddrDatabase::NotifyCardEntryChange()
nsAddrDatabase::DeleteCard()
nsAbAddressCollecter::CollectAddress()
nsAbAddressCollecter::CollectUnicodeAddress()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Execute()
JS_EvaluateUCScriptForPrincipals()
nsJSContext::EvaluateString()
GlobalWindowImpl::RunTimeout()
GlobalWindowImpl::TimerCallback()
nsTimerImpl::Process()
handleMyEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xff9e (0x40393f9e)
libglib-1.2.so.0 + 0x11773 (0x40395773)
libglib-1.2.so.0 + 0x11d39 (0x40395d39)
libglib-1.2.so.0 + 0x11eec (0x40395eec)
libgtk-1.2.so.0 + 0x94333 (0x402b1333)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1c507 (0x404dc507) 


Incident ID 4741502
Stack Signature nsAddrDatabase::NotifyCardEntryChange() 9a3d327b
Email Address endico@mozilla.org
Product ID MozillaTrunk
Build ID 2002040108
Trigger Time 2002-04-02 10:44:45
Platform LinuxIntel
Operating System Linux 2.4.7-10
Module libaddrbook.so
URL visited
User Comments
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Source File Name
Trigger Line No.
Stack Trace
nsAddrDatabase::NotifyCardEntryChange()
nsAddrDatabase::DeleteCard()
nsAbAddressCollecter::CollectAddress()
nsAbAddressCollecter::CollectUnicodeAddress()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Execute()
JS_EvaluateUCScriptForPrincipals()
nsJSContext::EvaluateString()
GlobalWindowImpl::RunTimeout()
GlobalWindowImpl::TimerCallback()
nsTimerImpl::Process()
handleMyEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xff9e (0x40392f9e)
libglib-1.2.so.0 + 0x11773 (0x40394773)
libglib-1.2.so.0 + 0x11d39 (0x40394d39)
libglib-1.2.so.0 + 0x11eec (0x40394eec)
libgtk-1.2.so.0 + 0x94333 (0x402b0333)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1c507 (0x404db507)
(Reporter)

Comment 1

17 years ago
laurel had a similar crash. her talkback comment:
"crash dragging AB card to another book"

so did ccomb:
"In the address, book, I was drag'n'dropping addresses from the collected
addresses to the personnal adrress book. I also was trying to reproduce the bug
127636 (I had just filtered the collected address book, and unsuccessfully tried
to delete an address"

it looks like deleting address cards is dangerous.

this seems to be a dup of bug 127636 although the stacks are different.
the behaviour preceeding the crash is the same although in this bug the
crash doesn't happen immediately.

in that bug ccomb says: come to think of it, i gues that's what i did too.


initial condition : must have many collected addresses in adress book.

- display the list of collected adresses
- try to delete a few adresses -> OK
- enter a search string (in "Name or Email contains:") to display only a few
collected adresses
- try to delete a few adresses from the filtered list -> IMPOSSIBLE
- remove the search string to display all the adresses
- try to delete the first address of the list -> CRASH
Keywords: crash
(Reporter)

Comment 2

17 years ago
I searched talkback for all stack signatures with
"nsAddrDatabase::NotifyCardEntryChange()" and all the Mozilla entries were
linux.
(Reporter)

Comment 3

17 years ago
hopefully the recent fix for bug 138619 (and 117452) will fix this
bug (and bug 127636).
mass re-assign.
Assignee: racham → sspitzer

Comment 5

15 years ago
(In reply to bug 139653 comment #3)
> hopefully the recent fix for bug 138619 (and 117452) will fix this
> bug (and bug 127636).

Has this behavior been fixed as anticipated back in April 2002?  Can anyone
reproduce this crash or hang?

Comment 6

15 years ago
marking wfm per comment in 127636.  Please reopen if the reporter or anyone else
still experiences this bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.