Firefox crashes after update glib2 from 2.46.2 to 2.50.3

VERIFIED INVALID

Status

()

VERIFIED INVALID
a year ago
a year ago

People

(Reporter: josep.sanz, Unassigned)

Tracking

({crash})

55 Branch
Unspecified
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824123605

Steps to reproduce:

Execute firefox using the glib2-2.50.3


Actual results:

NORMAL EXECUTION FROM TERMINAL:

[sanz@localhost ~]$ firefox --new-instance

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:2989:31: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:2992:33: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:2996:33: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3177:25: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3182:31: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3187:32: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3192:34: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3197:33: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3202:39: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3207:40: Missing name of pseudo-class

(firefox:30153): Gtk-WARNING **: Theme parsing error: gtk.css:3212:42: Missing name of pseudo-class

(firefox:30153): GLib-GObject-CRITICAL **: g_object_ref: assertion 'object->ref_count > 0' failed
ExceptionHandler::GenerateDump cloned child 30274
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Segmentation fault
[sanz@localhost code]$ 
(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:2989:31: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:2992:33: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:2996:33: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3177:25: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3182:31: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3187:32: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3192:34: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3197:33: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3202:39: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3207:40: Missing name of pseudo-class

(crashreporter:30275): Gtk-WARNING **: Theme parsing error: gtk.css:3212:42: Missing name of pseudo-class

AND USING GDB:

[sanz@localhost ~]$ gdb --args firefox --new-instance
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-94.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/firefox/firefox...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/local/bin/firefox --new-instance
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Detaching after fork from child process 28891.
[New Thread 0x7fffe685f700 (LWP 28892)]
[Thread 0x7fffe685f700 (LWP 28892) exited]
Detaching after fork from child process 28893.
[New Thread 0x7fffe685f700 (LWP 28997)]
[New Thread 0x7fffdba1e700 (LWP 28998)]
[New Thread 0x7fffdb0ff700 (LWP 28999)]
[New Thread 0x7fffda8fe700 (LWP 29000)]
[New Thread 0x7fffd9eff700 (LWP 29001)]
[New Thread 0x7fffd96fe700 (LWP 29002)]
[New Thread 0x7fffd94fd700 (LWP 29003)]
[New Thread 0x7fffd92fc700 (LWP 29004)]
[New Thread 0x7fffd90fb700 (LWP 29005)]
[New Thread 0x7fffd8efa700 (LWP 29006)]
[New Thread 0x7fffd8cf9700 (LWP 29007)]
[New Thread 0x7fffd8af8700 (LWP 29008)]
[New Thread 0x7fffd88f7700 (LWP 29009)]
[New Thread 0x7fffd81ff700 (LWP 29010)]
[New Thread 0x7fffd6158700 (LWP 29011)]
[New Thread 0x7fffd5957700 (LWP 29012)]

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:2989:31: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:2992:33: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:2996:33: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3177:25: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3182:31: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3187:32: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3192:34: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3197:33: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3202:39: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3207:40: Missing name of pseudo-class

(firefox:28887): Gtk-WARNING **: Theme parsing error: gtk.css:3212:42: Missing name of pseudo-class

(firefox:28887): GLib-GObject-CRITICAL **: g_object_ref: assertion 'object->ref_count > 0' failed

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff20c7efb in g_type_class_meta_marshal () from /lib64/libgobject-2.0.so.0
Missing separate debuginfos, use: debuginfo-install firefox-55.0.3-1.x86_64

AS AN EXTRA:

if I execute the firefox command using the libgobject of the glib2-2.46.2 package, firefox runs as expected!!!:

[sanz@localhost ~]$ LD_PRELOAD=/opt/firefox/libgobject-2.0.so.0.4600.2 firefox


Expected results:

The typical browser window.
Component: Untriaged → Widget: Gtk
Keywords: crash
OS: Unspecified → Linux
Product: Firefox → Core
Josep, Could this occur on our official binary from https://www.mozilla.org/en-US/firefox/ ?   If this occurs on RedHat package only, please file a bug to https://bugzilla.redhat.com/
Flags: needinfo?(josep.sanz)
(Reporter)

Comment 2

a year ago
Hi Makoto.

This occur on your official binary package called firefox-55.0.3.tar.bz2 downloaded from the mozilla page.

Josep.
Flags: needinfo?(josep.sanz)
(Reporter)

Comment 3

a year ago
Hi.

As a temporal solution, I have modified the libmozgtk.so in my local installation. To do it:

1) Obtain and put the old libgobject-2.0.so.0.4600.2 to the /opt/firefox

2) patchelf --add-needed /opt/firefox/libgobject-2.0.so.0.4600.2 /opt/firefox/libmozgtk.so

3) patchelf --print-needed /opt/firefox/libmozgtk.so

        /opt/firefox/libgobject-2.0.so.0.4600.2
        libpthread.so.0
        libdl.so.2
        libgtk-3.so.0
        libgdk-3.so.0
        libstdc++.so.6
        libm.so.6
        libc.so.6

Now, firefox runs without problems!!!

Josep.
(Reporter)

Comment 4

a year ago
Hi.

After the CentOS 7.4 update, the original package (firefox-55.0.3.tar.bz2) runs as expected.

I understand that the problem was some incompatibility between the glib2 and some other library and that was fixed after the update.

Sorry and thanks by your help.

Josep.
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Updated

a year ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.