Closed Bug 1396563 Opened 2 years ago Closed 2 years ago

L10n Dailies broken: Windows since 19-Aug-2017, Mac/Linux since 24-Aug-2017

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jorgk, Assigned: tomprince)

References

Details

Attachments

(2 files)

Windows:

http://ftp.mozilla.org/pub/thunderbird/nightly/2017/09/2017-09-04-03-02-07-comm-central-l10n/comm-central-win32-l10n-nightly-zh-CN-bm74-build1-build2570.txt.gz
says:
IOError: [Errno 2] c:\builds\moz2_slave\tb-c-cen-w32-l10n-ntly-0000000\build\comm-central\mozilla\browser/extensions/shield-recipe-client/test/unit/mock_api/api/v1/action/preference-experiment/implementation/sha384-KQgG38GQ7KZAb2VIB48ANQO6nBcxZoLm2ORzUviRT5nAvSywyPjZ5cJIElw6iXIt: The system cannot find the path specified

Linux/Mac:

http://ftp.mozilla.org/pub/thunderbird/nightly/2017/09/2017-09-04-03-02-07-comm-central-l10n/comm-central-macosx64-l10n-nightly-zh-TW-bm85-build1-build2570.txt.gz
http://ftp.mozilla.org/pub/thunderbird/nightly/2017/09/2017-09-04-03-02-07-comm-central-l10n/comm-central-linux64-l10n-nightly-zh-TW-bm73-build1-build1759.txt.gz

says:
Error: Locale doesn't have a manifest entry for 'devtools-shim'
Traceback (most recent call last):
  File "/builds/slave/tb-c-cen-m64-l10n-ntly-0000000/build/comm-central/mozilla/toolkit/mozapps/installer/l10n-repack.py", line 59, in <module>
    main()
  File "/builds/slave/tb-c-cen-m64-l10n-ntly-0000000/build/comm-central/mozilla/toolkit/mozapps/installer/l10n-repack.py", line 55, in main
    non_resources=args.non_resource, non_chrome=NON_CHROME)
  File "/builds/slave/tb-c-cen-m64-l10n-ntly-0000000/build/comm-central/mozilla/python/mozbuild/mozpack/packager/l10n.py", line 269, in repack
    _repack(app_finder, l10n_finder, copier, formatter, non_chrome)
  File "/tools/python/lib/python2.7/contextlib.py", line 24, in __exit__
    self.gen.next()
  File "/builds/slave/tb-c-cen-m64-l10n-ntly-0000000/build/comm-central/mozilla/python/mozbuild/mozpack/errors.py", line 131, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
make[1]: *** [repackage-zip] Error 1
make: *** [repackage-zip-zh-TW] Error 2
Flags: needinfo?(mozilla)
"L10n Dailies are a constant problem, they break all the time and no one notices" is still a problem, that was the original summary of bug 1385642.
The devtools shim is bug 1386616, which probably needs a vanilla copy-n-paste patch.

The windows one is a problem with path lengths on windows, I assume.
Thanks.

I could try to pick bits from https://hg.mozilla.org/mozilla-central/rev/bae931220733 but the browser and mail files don't quite match, for example we don't have these:
https://hg.mozilla.org/mozilla-central/rev/bae931220733#l1.30
https://hg.mozilla.org/mozilla-central/rev/bae931220733#l3.12

The other three hunks could be ported. Of course it would be better if someone did it who knows what they're doing.
Comment on attachment 8904245 [details] [diff] [review]
1396563-devtools-shim.patch

Review of attachment 8904245 [details] [diff] [review]:
-----------------------------------------------------------------

hrmpf, devtools/shim isn't going to work as is, we either need to create an l10n.ini file in devtools/shim/locales (doh) or update compare-locales in m-c to use the toml files. Which will allow to just use devtools/shim as path in mozilla.

I'd like to land compare-locales anyway, but I have to align a few other things first. I'm tracking that in bug 1382005.

The patch goes in the right direction, but the filter.py work is tied to the ini file, and the ini file won't work as it :-/
Attachment #8904245 - Flags: feedback?(l10n)
Axel, thanks for looking at it. I'm afraid I'll have to leave it to someone one more knowledgable. There's also bug 1392245 in this area.
Duplicate of this bug: 1396475
(In reply to Axel Hecht [:Pike] from comment #5)
> I'd like to land compare-locales anyway, but I have to align a few other
> things first. I'm tracking that in bug 1382005.

Now that bug 138205 has been fixed.
Assignee: nobody → mozilla
Flags: needinfo?(mozilla)
Keywords: leave-open
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/c731b22f588d
Port Bug 1382005 to calendar: Update compare-locales invocation; rs=bustage-fix
https://hg.mozilla.org/comm-central/rev/535c47ddb055
Port bug 1386616 to C-C [Move devtools key-shortcuts.properties out of the devtools addon]. rs=bustage-fix
Hmm, some of it was supposedly my code, I can't remember any of it. I hope you picked the correct hunks ;-) Thanks!
Depends on: 1405840
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/5cdc0ea5bca1
Disable configuring stylo for L10N builds; rs=bustage-fix
Comment on attachment 8904245 [details] [diff] [review]
1396563-devtools-shim.patch

Review of attachment 8904245 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/locales/l10n.toml
@@ +96,5 @@
>      path = "{mozilla}/toolkit/locales/l10n.toml"
>  
> +[[paths]]
> +    reference = "{mozilla}/devtools/shim/locales/en-US/**"
> +    l10n = "{l}{mozilla}/devtools/shim/**"

The l10n path is wrong, follow-up coming.
Attachment #8904245 - Flags: review-
Comment on attachment 8916939 [details] [diff] [review]
correct the l10n path for devtools/shim

Thanks for the patch. I'll let Tom deal with this.
Attachment #8916939 - Flags: review?(jorgk) → review?(mozilla)
Comment on attachment 8916939 [details] [diff] [review]
correct the l10n path for devtools/shim

Nice catch. Thanks.
Attachment #8916939 - Flags: review?(mozilla) → review+
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/e6c1d0bc8fa5
Correct the l10n path for devtools/shim; r=tomprince
Windows is broken on bug 1366607 comment 21, I would think this should be broken for all platforms.
(In reply to Philipp Kewisch [:Fallen] from comment #18)
> I would think this should be broken for all platforms.
Sorry. You're right.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1415064
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.