Closed Bug 1396704 Opened 2 years ago Closed 2 years ago

Intermittent test_FrameSelection.html,test_HaveMetadataUnbufferedSeek.html,test_EndedEvent.html | application crashed [@ mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::~Log] after Assertion failure: [GFX1]: GLBlitHelper requires vertex_array_object

Categories

(Core :: Graphics, defect, P1, critical)

defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgilbert)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: gfx-noted [stockwell fixed:product])

Crash Data

Attachments

(1 file)

Assignee: nobody → jgilbert
Priority: P5 → P1
Whiteboard: gfx-noted
Comment on attachment 8904786 [details]
Bug 1396704 - Support GLBlitHelper without VAOs. -

https://reviewboard.mozilla.org/r/176558/#review181612

LGTM
Attachment #8904786 - Flags: review?(dmu) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/34767394af0d
Support GLBlitHelper without VAOs. - r=daoshengmu
Summary: Intermittent dom/media/mediasource/test/test_FrameSelection.html | application crashed [@ mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::~Log] after Assertion failure: [GFX1]: GLBlitHelper requires vertex_array_object → Intermittent test_FrameSelection.html,test_HaveMetadataUnbufferedSeek.html | application crashed [@ mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::~Log] after Assertion failure: [GFX1]: GLBlitHelper requires vertex_array_object
https://hg.mozilla.org/mozilla-central/rev/34767394af0d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Whiteboard: gfx-noted → gfx-noted [stockwell fixed:product]
Hi Sebastian, 
I've noticed that this intermittent failure is still occurring.
Can you, please, take a look?
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=3bf241aaf148d15b14b4af87628ab9f5b14f6a75&selectedJob=129158635
Flags: needinfo?(aryx.bugmail)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(aryx.bugmail) → needinfo?(jgilbert)
Whiteboard: gfx-noted [stockwell fixed:product] → gfx-noted [stockwell needswork]
Summary: Intermittent test_FrameSelection.html,test_HaveMetadataUnbufferedSeek.html | application crashed [@ mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::~Log] after Assertion failure: [GFX1]: GLBlitHelper requires vertex_array_object → Intermittent test_FrameSelection.html,test_HaveMetadataUnbufferedSeek.html,test_EndedEvent.html | application crashed [@ mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::~Log] after Assertion failure: [GFX1]: GLBlitHelper requires vertex_array_object
Duplicate of this bug: 1400755
Oh, I never removed the assert.
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a002b031156
Remove assert, which was the whole point of this bug.
Blocks: 1401090
https://hg.mozilla.org/mozilla-central/rev/2a002b031156
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Whiteboard: gfx-noted [stockwell needswork] → gfx-noted [stockwell fixed:product]
You need to log in before you can comment on or make changes to this bug.