[Onboarding] Font is hardly readable on onboarding banners on high resolution screens at least on W10

VERIFIED FIXED in Firefox 57

Status

()

P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: clement.lefevre, Assigned: gasolin)

Tracking

({nightly-community})

57 Branch
Firefox 57
nightly-community
Points:
---

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: [photon-onboarding][mozfr-community])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
The new onboarding banner can use a hardly readable font and font-size on high-resolution screens (see the joined screenshot, only a full HD screen with a maximized window).

This was reproduced using a clean profile on a Windows 10 computer.
(Reporter)

Updated

2 years ago
Keywords: nightly-community
Whiteboard: [mozfr-community]
(Assignee)

Updated

2 years ago
Whiteboard: [mozfr-community] → [photon-onboarding][triage][mozfr-community]
Flags: needinfo?(mverdi)
What's the physical size of your Full HD screen? Web has no access to the physical size of your pixels, and expect your device to show 1 css pixel with 1/96 - 1/125 inch width/height.

You should scale up your screen with proper display scaling settings.

https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices

Recommending WONTFIX, leaving ni for our designer to confirm.
(Reporter)

Comment 2

2 years ago
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #1)
> What's the physical size of your Full HD screen? Web has no access to the
> physical size of your pixels, and expect your device to show 1 css pixel
> with 1/96 - 1/125 inch width/height.
> 
> You should scale up your screen with proper display scaling settings.
> 
> https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-
> high-dpi-devices
> 
> Recommending WONTFIX, leaving ni for our designer to confirm.

It's a Full HD screen on a standard 15" laptop with a 100% scale.
Nothing out of the standards.

Other texts are fine, only the banner one is difficult to read because letters lines are too thin and/or not antialiased.
It looks like we changed the spec from normal weight text to light. Let's change the body copy back to normal. That should fix it.
Flags: needinfo?(mverdi)
(Reporter)

Comment 4

2 years ago
By the way, creating a new profile, I noticed this is not easier to read on another computer running Windows 7 with a 1280x1024 screen.
(Assignee)

Updated

2 years ago
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Updated

2 years ago
Whiteboard: [photon-onboarding][triage][mozfr-community] → [photon-onboarding][mozfr-community]
Comment on attachment 8905742 [details]
Bug 1396734 - Set onboarding-notification-body font weight to normal to avoid font bluring on windows;

https://reviewboard.mozilla.org/r/177542/#review182732
Attachment #8905742 - Flags: review?(rexboy) → review+
Component: General → New Tab Page

Comment 7

2 years ago
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/529bfc306853
Set onboarding-notification-body font weight to normal to avoid font bluring on windows;r=rexboy
https://hg.mozilla.org/mozilla-central/rev/529bfc306853
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Comment 9

2 years ago
Interesting that you had a display weight (200) for *body text*. This is never a good idea. For the future, here’s a nice read: http://www.telegraph.co.uk/science/2016/10/23/internet-is-becoming-unreadable-because-of-a-trend-towards-light/
Flags: qe-verify+
QA Contact: jwilliams
I can confirm this issue is no longer available. I verified using Fx 57.0b7, on Windows 10 x64.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
I have verified that this issue is no longer reproducible on Win 10 x64 with Firefox 58.
status-firefox58: --- → verified
You need to log in before you can comment on or make changes to this bug.