Closed Bug 1396835 Opened 7 years ago Closed 7 years ago

Editing a Top Site URL wrongly creates a new Top Site

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- verified
firefox58 --- unaffected

People

(Reporter: cmuresan, Assigned: andreio)

References

Details

Attachments

(1 file)

[Affected versions]:
- Firefox 57.0a1 Build ID 20170904220027

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- browser.newtabpage.activity-stream.enabled is set to true in about:config on a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a New Tab.
2. Click the "Edit" button from the Top Sites section.
3. Click the "Pencil" for one of the Top Sites.
4. Edit the URL and save.
5. Hover the previously edited Top site and observe the URL.

[Expected results]:
- The Top Site URL was edited.

[Actual results]:
- The Top Site URL was not edited and a new Top Site with the edited URL is created.

[Notes]:
- If you create two Top Sites in this way, when you dismiss one of them, both will be removed,
- Attached a screen recording of the issue.
Assignee: nobody → andrei.br92
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

I've retested this issue on Windows 10 and Ubuntu 16.04 with the latest Nightly (Build ID 20170913220121) on Mac 10.12 with Nightly build ID 20170914100122. When a Top Site URL is edited a new one is still created and the "edited" one is moved to the right. This is the exact behavior described in comment 0. 

@Mardak, are the changes not in the latest Nightly?
Status: RESOLVED → REOPENED
Flags: needinfo?(edilee)
Resolution: FIXED → ---
Ah indeed. The code did make it to Nightly, but it seems like it's not actually fixed.
Flags: needinfo?(edilee) → needinfo?(andrei.br92)
Fixed by https://github.com/mozilla/activity-stream/pull/3516 to be uplifted via bug 1400601.
Blocks: 1400601
No longer blocks: 1398239
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(andrei.br92)
Resolution: --- → FIXED
The issue is no longer reproducible on the latest Nightly 58.0a1 (buildid 20170925220207) or on the latest beta 57.0b2. I have verified it on Windows 10, Mac 10.12 and Arch Linux.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: