Closed Bug 1396876 Opened 2 years ago Closed 2 years ago

When the browser is started, location bar gets focus instead of about:home search field

Categories

(Firefox :: Tabbed Browser, defect)

57 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1395961

People

(Reporter: alice0775, Unassigned)

Details

(Keywords: multiprocess, regression)

[Tracking Requested - why for this release]: Focus event regression.


This is a regression since Night57.0a1.
And this is a inconsistent behavior because about:home search field gets focus when I open about:home again.

This problem only occurs after the browser window is displayed.
And This problem is only on Nightly57.0a1 with e10s.


Reproducible: always

Steps To Reproduce:
1. Make sure option set "Show my home page" when Firefox starts. (default)
2. Launch browser or open new window.


Actual Results:
Location bar gets focus.

Expected Results:
about:home search field should get focus.


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5ce04b2110b31e6d4d47c57c68fde6164bbf9cc0&tochange=96351b2f544acf6199636f04de31f39276ee4767

Suspected:
4722bf29a176	Samael Wang — Bug 1394132 - Ensure we only handle focus event once. r=masayuki
No longer blocks: 1394132
oopps

Suspected:
434a7900c855	Dão Gottwald — Bug 1393802 - Make about:home's identity block consistent with about:newtab's. r=florian
Blocks: 1393802
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1395961
You need to log in before you can comment on or make changes to this bug.