[Form Autofill] Use the terminology of the user/form when providing information about form autofill

RESOLVED DUPLICATE of bug 1396872

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 1396872
3 months ago
3 months ago

People

(Reporter: B.J. Herbison, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

3 months ago
Steps to reproduce:
* Visit the form autofill demo. https://luke-chang.github.io/autofill-demo/basic.html
* Fill in the form including the Name and Organization fields and submit.
* Clear the form.
* Click in the Name field and preview the saved address.

Expected result:

* The Form Autofill pop-up says "Also autofills the Organization field".

Actual result:

* The Form Autofill pop-up says "Also autofills the company field".

The message is surprising as there is no "company" field to fill in. The field is labeled Organization: so from the user's point of view the information to be filled in for the organization, not company.

This applies to any field, not just company/organization. But company is especially problematic as the field name in the autocomplte standard is "organization", not "company".

Comment 1

3 months ago
It's a similar problem to bug 1396872 about field grouping and their names. 

I'm going to close this bug, but feel free to reopen it if I misunderstood it, thanks :)
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1396872
You need to log in before you can comment on or make changes to this bug.