Closed Bug 1396912 Opened 3 years ago Closed 3 years ago

Stub installer progress bar stops moving at a certain point for some time

Categories

(Firefox :: Installer, defect)

All
Windows
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: Abe_LV, Assigned: mhowell)

References

Details

Attachments

(1 file)

Steps to reproduce:

Screen capture: https://testing-1.tinytake.com/sf/MTkyOTk3OF82MTQxODMx

1. Run the stub installer
2. Observe the progress bar 

Actual Result:

The progress bar stops moving at a certain point for few seconds before it exists.

Expected result:
The progress bar should keep filling up until it reaches 100%.
Blocks: 1376597
Flags: needinfo?(mhowell)
I have a hunch about what's going on, but I haven't been able to reproduce this in order to verify it. Abe, do you think you could get a screen capture of the entire installation, starting from when the installer window first appears? That would be super helpful. Thanks.
Flags: needinfo?(mhowell) → needinfo?(amasresha)
Here is the screen capture: https://testing-1.tinytake.com/sf/MTkzMDYwNF82MTQzMTg0

I am on windows 10 64 bits OS.
--
Version 	57.0a1
Build ID 	20170905100117
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Flags: needinfo?(amasresha)
Thanks, that's perfect. What's happening is that the bar is filling up too quickly during the install phase, so it gets to where it would be at the end of that phase well before the install operation is actually done. This is because I forgot to scale the bar position by the install timeout. Patch coming up.
Comment on attachment 8904759 [details]
Bug 1396912 - Advance the stub installer progress bar at the correct rate during the install phase.

https://reviewboard.mozilla.org/r/176542/#review181582

Looks good, sorry I missed this last time. I didn't think we'd want the install phase to progress so slowly, but also didn't realize how bad the pause would look.
Attachment #8904759 - Flags: review?(agashlin) → review+
Comment on attachment 8904759 [details]
Bug 1396912 - Advance the stub installer progress bar at the correct rate during the install phase.

https://reviewboard.mozilla.org/r/176542/#review181582

I agree it's not ideal, but it will at least match the previous behavior this way.
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fdb66df9fbc2
Advance the stub installer progress bar at the correct rate during the install phase. r=agashlin
https://hg.mozilla.org/mozilla-central/rev/fdb66df9fbc2
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
verified as fixed.
Status: RESOLVED → VERIFIED
Assignee: nobody → mhowell
You need to log in before you can comment on or make changes to this bug.