Intermittent /webdriver/tests/minimize_window.py | minimize_window.py::test_minimize

RESOLVED FIXED in Firefox 58

Status

Testing
geckodriver
P5
normal
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: Treeherder Bug Filer, Assigned: ato)

Tracking

({intermittent-failure})

Version 3
mozilla58
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 disabled, firefox58 fixed)

Details

(Whiteboard: [stockwell fixed])

[task 2017-09-06T00:08:47.047825Z] 00:08:47     INFO - TEST-UNEXPECTED-FAIL | /webdriver/tests/minimize_window.py | minimize_window.py::test_minimize 
[task 2017-09-06T00:08:47.048859Z] 00:08:47     INFO - session = <webdriver.client.Session object at 0x7ff41ac04710>
[task 2017-09-06T00:08:47.049832Z] 00:08:47     INFO - 
[task 2017-09-06T00:08:47.050464Z] 00:08:47     INFO -     def test_minimize(session):
[task 2017-09-06T00:08:47.051096Z] 00:08:47     INFO -         assert not session.execute_script("return document.hidden")
[task 2017-09-06T00:08:47.051505Z] 00:08:47     INFO -     
[task 2017-09-06T00:08:47.052246Z] 00:08:47     INFO -         # step 4
[task 2017-09-06T00:08:47.052664Z] 00:08:47     INFO -         response = minimize(session)
[task 2017-09-06T00:08:47.053391Z] 00:08:47     INFO -         assert_success(response)
[task 2017-09-06T00:08:47.054121Z] 00:08:47     INFO -     
[task 2017-09-06T00:08:47.054861Z] 00:08:47     INFO - >       assert session.execute_script("return document.hidden")
[task 2017-09-06T00:08:47.055265Z] 00:08:47     INFO - E       assert <bound method Session.execute_script of <webdriver.client.Session object at 0x7ff41ac04710>>('return document.hidden')
[task 2017-09-06T00:08:47.055677Z] 00:08:47     INFO - E        +  where <bound method Session.execute_script of <webdriver.client.Session object at 0x7ff41ac04710>> = <webdriver.client.Session object at 0x7ff41ac04710>.execute_script

Similar to bug 1392907. So maybe the patch on bug 1396618 might help too.
Depends on: 1396618

Comment 2

6 months ago
40 failures in 205 pushes (0.195 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 26
* autoland: 7
* mozilla-central: 5
* try: 2

Platform breakdown:
* linux64: 37
* linux64-ccov: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-06&endday=2017-09-06&tree=all

Updated

5 months ago
See Also: → bug 1397007

Updated

5 months ago
Whiteboard: [stockwell needswork]

Comment 3

5 months ago
32 failures in 173 pushes (0.185 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 12
* autoland: 8
* try: 6
* mozilla-central: 6

Platform breakdown:
* linux64: 28
* linux64-ccov: 3
* linux64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-07&endday=2017-09-07&tree=all

Comment 4

5 months ago
30 failures in 173 pushes (0.173 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 15
* try: 6
* mozilla-inbound: 6
* mozilla-central: 3

Platform breakdown:
* linux64: 28
* linux64-devedition: 1
* linux64-ccov: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-08&endday=2017-09-08&tree=all

Comment 5

5 months ago
17 failures in 64 pushes (0.266 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 8
* autoland: 8
* try: 1

Platform breakdown:
* linux64: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-09&endday=2017-09-09&tree=all

Comment 6

5 months ago
146 failures in 924 pushes (0.158 failures/push) were associated with this bug in the last 7 days. 

This is the #13 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-inbound: 58
* autoland: 51
* try: 19
* mozilla-central: 18

Platform breakdown:
* linux64: 134
* linux64-ccov: 7
* linux64-nightly: 3
* linux64-devedition: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-04&endday=2017-09-10&tree=all
This failure also started on Sep 5th so it's similar to the other top failure on bug 1397007.
Flags: needinfo?(ato)

Comment 8

5 months ago
25 failures in 159 pushes (0.157 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 10
* autoland: 8
* try: 5
* mozilla-central: 2

Platform breakdown:
* linux64: 22
* linux64-ccov: 2
* linux64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-11&endday=2017-09-11&tree=all
(Assignee)

Comment 9

5 months ago
(In reply to Henrik Skupin (:whimboo) from comment #7)

> This failure also started on Sep 5th so it's similar to the other
> top failure on bug 1397007.

See my feedback to this in
https://bugzilla.mozilla.org/show_bug.cgi?id=1397007#c11.

These two bugs are indeed caused by the same underlying problem.
When we figure out what the right solution for fixing it is, we
should mark both bugs dependent.
Flags: needinfo?(ato)

Comment 10

5 months ago
19 failures in 162 pushes (0.117 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 9
* autoland: 6
* mozilla-central: 3
* try: 1

Platform breakdown:
* linux64: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-12&endday=2017-09-12&tree=all

Comment 11

5 months ago
65 failures in 1032 pushes (0.063 failures/push) were associated with this bug in the last 7 days. 

This is the #40 most frequent failure this week.   

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* mozilla-inbound: 24
* autoland: 23
* try: 11
* mozilla-central: 7

Platform breakdown:
* linux64: 59
* linux64-ccov: 4
* linux64-nightly: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-11&endday=2017-09-17&tree=all
Whiteboard: [stockwell needswork] → [stockwell disable-recommended]
this looked to be fixed as of September 13th?  is there a reference to a patch?
Whiteboard: [stockwell disable-recommended] → [stockwell unknown]
(Assignee)

Comment 13

5 months ago
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #12)

> this looked to be fixed as of September 13th? is there a reference
> to a patch?

This will get fixed with https://bugzil.la/1400226, which has a
dependency on https://bugzil.la/1400225.  The latter is currently in
review.
Depends on: 1400226
(Assignee)

Comment 14

5 months ago
This intermittent has the same underlying issue as
https://bugzil.la/1397007.
Skipped on Linux on Beta.
https://hg.mozilla.org/releases/mozilla-beta/rev/b8028ef01cb6
status-firefox57: --- → disabled
Andreas, can you make sure that the test on beta gets re-enabled? The patch from bug 1400226 should be already on that branch.
Flags: needinfo?(ato)

Comment 17

5 months ago
1 failures in 885 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* try: 1

Platform breakdown:
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397069&startday=2017-09-25&endday=2017-10-01&tree=all
Whiteboard: [stockwell unknown] → [stockwell disable-recommended]
Andreas, this should be fixed on at least central. Would we have to keep the test disabled on beta?
(Assignee)

Comment 19

5 months ago
(In reply to Henrik Skupin (:whimboo) from comment #18)

> [T]his should be fixed on at least central. Would we have to keep
> the test disabled on beta?

Leaving this test disabled on beta is probably wise so that it
doesn’t appear like Firefox is having intermittency issues.
Flags: needinfo?(ato)
Ok, so going to mark it as fixed for Firefox 58.0.
Assignee: nobody → ato
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Whiteboard: [stockwell disable-recommended] → [stockwell fixed]
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.