Intermittent test_quit_restart.py TestServerQuitApplication.test_empty_default | application crashed [@ mozilla::loader::OutputBuffer::codeString][@ libc-2.23.so + 0x15e470][@ Checker::StartReadOp()]

RESOLVED FIXED in Firefox 57

Status

()

Core
XPConnect
P5
critical
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: Treeherder Bug Filer, Assigned: kmag)

Tracking

({crash, intermittent-failure, regression})

unspecified
mozilla57
crash, intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(crash signature)

Kris, looks like you've been touching this code a lot lately?
Flags: needinfo?(kmaglione+bmo)
Looks like we have different crash signatures here. Lets combine all crash signatures for the same Marionette unit test in this bug.
Blocks: 1397587, 1363482
Crash Signature: [@ mozilla::loader::OutputBuffer::codeString] → [@ mozilla::loader::OutputBuffer::codeString] [@ libc-2.23.so + 0x15e470] [@ Checker::StartReadOp()]
status-firefox57: --- → affected
Depends on: 1396366
Keywords: regression
Summary: Intermittent test_quit_restart.py TestServerQuitApplication.test_empty_default | application crashed [@ mozilla::loader::OutputBuffer::codeString] → Intermittent test_quit_restart.py TestServerQuitApplication.test_empty_default | application crashed [@ mozilla::loader::OutputBuffer::codeString][@ libc-2.23.so + 0x15e470][@ Checker::StartReadOp()]
Duplicate of this bug: 1397616

Comment 4

9 months ago
3 failures in 924 pushes (0.003 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 3

Platform breakdown:
* linux64: 2
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397073&startday=2017-09-04&endday=2017-09-10&tree=all
Should be fixed now via the patch on bug 1396366.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox56: --- → unaffected
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → kmaglione+bmo
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
Flags: needinfo?(kmaglione+bmo)

Comment 6

8 months ago
1 failures in 1032 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* linux64-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397073&startday=2017-09-11&endday=2017-09-17&tree=all
You need to log in before you can comment on or make changes to this bug.