In OS X 10.11.6, Cmd-Click to open link in new tab, and switching quickly will crash the tab

RESOLVED DUPLICATE of bug 1395708

Status

()

RESOLVED DUPLICATE of bug 1395708
a year ago
a year ago

People

(Reporter: mjf, Unassigned)

Tracking

({crash, steps-wanted})

57 Branch
crash, steps-wanted
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

a year ago
This is on up-to-date Nightly as of 8pm CDT on 2017/09/05 (Build ID 20170905220108)

First open the following link:
https://www.amazon.com/s/ref=nb_sb_noss_2?url=search-alias%3Daps&field-keywords=32GB+SD+card

I see cards in rows of three.  For me, the middle card on the 3rd row is "SanDisk Ultra 32GB microSDHC UHS-I card with Adapter - 98MB/s U1 A1 - SDSQUAR-032G-GN6MA"
and for reference the link is (https://www.amazon.com/SanDisk-Ultra-microSDHC-UHS-I-Adapter/dp/B073JWXGNT/ref=sr_1_8?s=pc&ie=UTF8&qid=1504658226&sr=1-8&keywords=32GB+SD+card)  It appears to be something particular to this page's content.

If I Cmd-click the link and then very quickly switch to the new tab using the cmd-opt-rightarrow keyboard shortcut, I get the error "Gah. Your tab just crashed."
If I Cmd-click the link and wait 1 second or more, and then switch to the new tab it loads fine.

Things I've tried:
Laptop running 10.12.6 - can't reproduce.
Desktop running 10.11.6 with e10s disabled - can't reproduce.
Desktop running 10.11.6 with all add-ons disabled - *can* reproduce.
Desktop running 10.11.6 and switching with a very quick mouse - *can* reproduce.
Reproducibility survives Desktop reboot.
It doesn't appear to be cache related since I can let the tab load, switch to it after a second or two, and then try the whole process again, and still get the crash.

I've seen this previously, but haven't recognized a pattern until now.

Comment 1

a year ago
Please send and provide links to the crash reports for these tab crashes (available by clicking the links in about:crashes, then just copy the URL from the URL bar).
Flags: needinfo?(mfroman)
(Reporter)

Comment 2

a year ago
I don't have nearly enough crash reports under about:crashes to account for the many, many times I exercised the crash yesterday.  I also had 2 crashes opening the about:support page, and I believe the only 2 crashes reports in the list for yesterday are for those.  I'll include them, here in case they help, but the crash for this bug doesn't seem to be captured.
https://crash-stats.mozilla.com/report/index/bp-6d5b6ccd-ecb0-4bc1-a848-e25080170906
https://crash-stats.mozilla.com/report/index/bp-1de07ceb-873a-4a68-af4b-3e3d70170906

I'll also note that trying to reproduce this morning doesn't work, but the item is no longer marked "deal of the day".  I wonder if that is related.  I'll try to find something else marked that way to see if it reproduces on that item.
Flags: needinfo?(mfroman)

Comment 3

a year ago
It looks like things are crashing in apple-land. Not clear why there's so little information in the crash report, or why there don't seem to be crash reports for all the crashes you've seen (per comment #2). :spohl, do you have ideas?
Component: Tabbed Browser → Untriaged
Flags: needinfo?(spohl.mozilla.bugs)
Keywords: crash, steps-wanted
Looks like a duplicate of bug 1395708.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(spohl.mozilla.bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1395708
You need to log in before you can comment on or make changes to this bug.