Closed Bug 1397086 Opened 2 years ago Closed 2 years ago

Bookmarks menu is less compact than in 55

Categories

(Firefox :: Menus, defect)

57 Branch
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1391625

People

(Reporter: u595893, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170905220108

Steps to reproduce:

STR

1 Install Firefox 55 and open bookmarks menu and see the size & support page also
2 Install Firefox 57 and do the same after setting the UI density to compact.

ER:Should be similar to 55
AR:Bookmarks have more padding and font size is larger
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Component: Untriaged → Menus
OS: Unspecified → All
Hardware: Unspecified → All
Summary: UI size and fonts size have increased even in compact UI → UI size of Menu and fonts size have increased even in compact UI compared to before
Virtual: Is this actually solely due to the work in bug 1374815? It's confusing that shellye set regression range to 'irrelevant' and then you changed it...
Flags: needinfo?(Virtual)
Summary: UI size of Menu and fonts size have increased even in compact UI compared to before → Bookmarks menu is less compact than in 55
Whiteboard: [photon-structure][triage]
I'm 99% sure that it is, as I also wanted to report this (more space between bookmarks/folders items) as issue, but looks like it was intended by bug #1374815 to get hamburger menu and bookmark menu style consistent.
Flags: needinfo?(Virtual)
Aaron, can you review this on Windows + OSX and check if you think the vertical size of the items in the bookmarks menu needs adjusting further?
Flags: needinfo?(abenson)
No, the menus are correct. The taller menu is arguably better since it can show more things.

I'm not sure if the expected behavior was tied to compact mode being set, so just to be clear, the compact setting is for toolbars and not the dropdown menus themselves.
Flags: needinfo?(abenson)
(In reply to Aaron Benson from comment #4)
> No, the menus are correct. The taller menu is arguably better since it can
> show more things.
> 

nope does the opposite takes more space to show same amount of data.
see the attachment the new one has more padding? and shows less even though is taller

> I'm not sure if the expected behavior was tied to compact mode being set, so
> just to be clear, the compact setting is for toolbars and not the dropdown
> menus themselves.

still compact one was better and would like to have it.
Flags: needinfo?(abenson)
Let's block this bug to bug #1391625, as maybe UX team will reevaluate and reconsider changing padding according to "Density" preference set in "Customize..." mode, so it will be smaller in Compact mode etc.
Status: UNCONFIRMED → NEW
Has Regression Range: irrelevant → yes
Ever confirmed: true
Keywords: ux-minimalism
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #6)
> Let's block this bug to bug #1391625, as maybe UX team will reevaluate and
> reconsider changing padding according to "Density" preference set in
> "Customize..." mode, so it will be smaller in Compact mode etc.

If that's what needs to happen this is just a dupe. No point tracking it separately, or as a regression.
No longer blocks: 1391625, 1374815
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(abenson)
Resolution: --- → DUPLICATE
Whiteboard: [photon-structure][triage]
Duplicate of bug: 1391625
You need to log in before you can comment on or make changes to this bug.