Move GetBStartBCBorderWidth, GetBEndBCBorderWidth and any similar methods' return type to BCPixelSize rather than nscoord

RESOLVED FIXED in Firefox 64

Status

()

P3
normal
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: ywu, Assigned: cpeterson)

Tracking

unspecified
mozilla64
Points:
---

Firefox Tracking Flags

(geckoview62 wontfix, firefox-esr60 wontfix, firefox57 wontfix, firefox58 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Per Bug Comment 21 mentioned, 

we should change these methods on nsTableRowFrame:
  nscoord GetBStartBCBorderWidth() const { return mBStartBorderWidth; }
  nscoord GetBEndBCBorderWidth() const { return mBEndBorderWidth; }
and any similar methods (like the two on nsTableColFrame) return BCPixelSize
rather than nscoord.
(Reporter)

Comment 1

a year ago
s/Per Bug Comment 21/Per Bug 895096 Comment 21
Priority: -- → P3
status-firefox57: --- → wontfix
status-firefox58: --- → affected
(Reporter)

Updated

10 months ago
Assignee: ywu → nobody
(Assignee)

Updated

2 months ago
Assignee: nobody → cpeterson
status-firefox58: affected → wontfix
status-firefox62: --- → wontfix
status-firefox63: --- → wontfix
status-firefox64: --- → affected
status-firefox-esr60: --- → wontfix
status-geckoview62: --- → wontfix
(Assignee)

Comment 2

2 months ago
Created attachment 9007488 [details]
Bug 1397119 - Part 1: Change nsTable*Frame::Get*BorderWidth() return values from nscoord to BCPixelSize. r?dbaron
(Assignee)

Comment 3

2 months ago
Created attachment 9007489 [details]
Bug 1397119 - Part 2: Rename p2t to d2a (app units per device pixel). r?dbaron

Bug 895096 comment 0 recommends using the name `d2a` instead of `p2t`.

Depends on D5368
Comment on attachment 9007488 [details]
Bug 1397119 - Part 1: Change nsTable*Frame::Get*BorderWidth() return values from nscoord to BCPixelSize. r?dbaron

David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-7 has approved the revision.
Attachment #9007488 - Flags: review+
Comment on attachment 9007489 [details]
Bug 1397119 - Part 2: Rename p2t to d2a (app units per device pixel). r?dbaron

David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-7 has approved the revision.
Attachment #9007489 - Flags: review+

Comment 6

2 months ago
Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6d0f8348cdb6
Part 1: Change nsTable*Frame::Get*BorderWidth() return values from nscoord to BCPixelSize. r=dbaron

Comment 7

2 months ago
Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8c95278f139
Part 2: Rename p2t to d2a (app units per device pixel). r=dbaron

Comment 8

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6d0f8348cdb6
https://hg.mozilla.org/mozilla-central/rev/c8c95278f139
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox64: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.