Closed Bug 1397145 Opened 6 years ago Closed 5 years ago

Remove moz-blob support from XHR

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

(Keywords: dev-doc-complete, site-compat)

Attachments

(1 file, 1 obsolete file)

In bug 1335365 I introduced Telemetry::MOZ_BLOB_IN_XHR to count how often moz-blob type is used in XHR. The result is: 0.16% I would like to proceed with removing this non-spec feature.
Attached patch moz_blob.patch (obsolete) — Splinter Review
Attachment #8904879 - Flags: review?(bugs)
0.16% sounds quite high, a lot higher than what I'd expect.
But where do you see that 0.16%.
Comment on attachment 8904879 [details] [diff] [review]
moz_blob.patch

I'd prefer if this landed only once FF57 is in beta.
Unless there is some particular reason to remove it now.

(We should try to avoid causing any possible regressions in 57)
Attachment #8904879 - Flags: review?(bugs) → review+
(In reply to Olli Pettay [:smaug] from comment #3)
> But where do you see that 0.16%.

If I do it correctly, I compare the number of MOZ_BLOB_IN_XHR and the number of any other ID sent by constantly. I used: NUMBER_OF_PROFILES because that ID is used at startup.
Green on try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=83377f20f8b02d994f47a56bc2ceb7562857f266&selectedJob=128876770

Please, land this patch when 57 is the new beta.
Keywords: checkin-needed
Whiteboard: to land when 57 is in beta
Keywords: dev-doc-needed
Attached patch moz_blob.patchSplinter Review
Attachment #8904879 - Attachment is obsolete: true
NI RyanVM to land this patch after 57
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cfb739b281f8
Remove the support for moz-blob type in XHR, r=smaug
Flags: needinfo?(ryanvm)
Whiteboard: to land when 57 is in beta
https://hg.mozilla.org/mozilla-central/rev/cfb739b281f8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Blocks: 1120171
I have documented this, by adding a note to the responseType page and removing the information about those values:

https://developer.mozilla.org/en-US/docs/Web/API/XMLHttpRequest/responseType#Browser_compatibility

And by adding a note to the Fx58 rel notes:

https://developer.mozilla.org/en-US/Firefox/Releases/58#APIs_2

Let me know if that looks OK. Thanks!
moz-chunked-arraybuffer has not been removed yet. It's used internally by PDFjs and probably something else.
Flags: needinfo?(cmills)
(In reply to Andrea Marchesini [:baku] from comment #13)
> moz-chunked-arraybuffer has not been removed yet. It's used internally by
> PDFjs and probably something else.

Ah, OK. I've added it back in to the values list, and updated the notes accordingly.
Flags: needinfo?(cmills)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.