Intermittent netwerk/test/unit/test_bug812167.js | xpcshell return code: 139

RESOLVED DUPLICATE of bug 1399773

Status

()

Core
Networking
P5
normal
RESOLVED DUPLICATE of bug 1399773
9 months ago
8 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=128811891&repo=autoland

https://queue.taskcluster.net/v1/task/SqrGVodJQvyxDNuVsgC2qQ/runs/0/artifacts/public/test_info//xpcshell_errorsummary.log

[task 2017-09-06T07:04:03.362207Z] 07:04:03     INFO -  TEST-START | netwerk/test/unit/test_bug812167.js
[task 2017-09-06T07:04:11.320491Z] 07:04:11  WARNING -  TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_bug812167.js | xpcshell return code: 139
[task 2017-09-06T07:04:11.321506Z] 07:04:11     INFO -  TEST-INFO took 7958ms
[task 2017-09-06T07:04:11.321598Z] 07:04:11     INFO -  >>>>>>>
[task 2017-09-06T07:04:11.321745Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | xpcw: cd /storage/sdcard/tests/xpc/netwerk/test/unit
[task 2017-09-06T07:04:11.322712Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | xpcw: xpcshell -r /storage/sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/target.apk -m -s -e const _HEAD_JS_PATH = "/storage/sdcard/tests/xpc/head.js"; -e const _MOZINFO_JS_PATH = "/storage/sdcard/tests/xpc/p/mozinfo.json"; -e const _TESTING_MODULES_DIR = "/storage/sdcard/tests/xpc/m"; -f /storage/sdcard/tests/xpc/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/storage/sdcard/tests/xpc/netwerk/test/unit/head_channels.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache2.js"]; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_bug812167.js"]; -e const _TEST_NAME = "netwerk/test/unit/test_bug812167.js" -e _execute_test(); quit(0);
[task 2017-09-06T07:04:11.323302Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | [8945] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 171
[task 2017-09-06T07:04:11.324633Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | Warning: MOZILLA_FIVE_HOME not set.
[task 2017-09-06T07:04:11.324708Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | [8945] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2872
[task 2017-09-06T07:04:11.324736Z] 07:04:11     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2017-09-06T07:04:11.324762Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | Segmentation fault
[task 2017-09-06T07:04:11.324785Z] 07:04:11     INFO -  netwerk/test/unit/test_bug812167.js | 13
[task 2017-09-06T07:04:11.324801Z] 07:04:11     INFO -  <<<<<<<
[task 2017-09-06T07:04:11.812168Z] 07:04:11     INFO -  mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpFQ3XxV/21bd6660-b401-9881-0105-19356b16146b.dmp /builds/worker/workspace/build/symbols
[task 2017-09-06T07:04:12.418974Z] 07:04:12     INFO -  mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/21bd6660-b401-9881-0105-19356b16146b.dmp
[task 2017-09-06T07:04:12.419852Z] 07:04:12     INFO -  mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/21bd6660-b401-9881-0105-19356b16146b.extra
[task 2017-09-06T07:04:12.419928Z] 07:04:12  WARNING -  PROCESS-CRASH | netwerk/test/unit/test_bug812167.js | application crashed [@ libxul.so + 0x595e8]
[task 2017-09-06T07:04:12.420773Z] 07:04:12     INFO -  Crash dump filename: /tmp/tmpFQ3XxV/21bd6660-b401-9881-0105-19356b16146b.dmp
[task 2017-09-06T07:04:12.420831Z] 07:04:12     INFO -  Operating system: Android
[task 2017-09-06T07:04:12.423360Z] 07:04:12     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l
[task 2017-09-06T07:04:12.423416Z] 07:04:12     INFO -  CPU: arm
[task 2017-09-06T07:04:12.423482Z] 07:04:12     INFO -       ARMv7 ARM Cortex-A8 features: swp,half,thumb,fastmult,vfpv2,edsp,neon,vfpv3
[task 2017-09-06T07:04:12.423524Z] 07:04:12     INFO -       1 CPU
[task 2017-09-06T07:04:12.423561Z] 07:04:12     INFO -  GPU: UNKNOWN
[task 2017-09-06T07:04:12.423601Z] 07:04:12     INFO -  Crash reason:  SIGSEGV
[task 2017-09-06T07:04:12.423639Z] 07:04:12     INFO -  Crash address: 0x0
[task 2017-09-06T07:04:12.423681Z] 07:04:12     INFO -  Process uptime: not available
[task 2017-09-06T07:04:12.423721Z] 07:04:12     INFO -  Thread 13 (crashed)
[task 2017-09-06T07:04:12.423761Z] 07:04:12     INFO -   0  libxul.so + 0x595e8
[task 2017-09-06T07:04:12.424079Z] 07:04:12     INFO -       r0 = 0x00000088    r1 = 0xc08bc7e8    r2 = 0xc08bc7e8    r3 = 0x00000000
[task 2017-09-06T07:04:12.424362Z] 07:04:12     INFO -       r4 = 0x45c0b544    r5 = 0x45c0b554    r6 = 0x45c0b570    r7 = 0x528ff5ac
[task 2017-09-06T07:04:12.424752Z] 07:04:12     INFO -       r8 = 0x528ff5ac    r9 = 0x4350938c   r10 = 0x4308175f   r12 = 0x00000003
[task 2017-09-06T07:04:12.425418Z] 07:04:12     INFO -       fp = 0x528ff5f4    sp = 0x528ff578    lr = 0x4071760b    pc = 0x407185e8
[task 2017-09-06T07:04:12.425517Z] 07:04:12     INFO -      Found by: given as instruction pointer in context
[task 2017-09-06T07:04:12.425664Z] 07:04:12     INFO -   1  libxul.so + 0x5b987
[task 2017-09-06T07:04:12.425975Z] 07:04:12     INFO -       sp = 0x528ff580    pc = 0x4071a989
[task 2017-09-06T07:04:12.426318Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.426668Z] 07:04:12     INFO -   2  libxul.so + 0x7187b
[task 2017-09-06T07:04:12.426964Z] 07:04:12     INFO -       sp = 0x528ff598    pc = 0x4073087d
[task 2017-09-06T07:04:12.427330Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.427715Z] 07:04:12     INFO -   3  libxul.so + 0x29b97da
[task 2017-09-06T07:04:12.428115Z] 07:04:12     INFO -       sp = 0x528ff59c    pc = 0x430787dc
[task 2017-09-06T07:04:12.428516Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.428915Z] 07:04:12     INFO -   4  libxul.so + 0x29c275d
[task 2017-09-06T07:04:12.429326Z] 07:04:12     INFO -       sp = 0x528ff5b0    pc = 0x4308175f
[task 2017-09-06T07:04:12.429624Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.430024Z] 07:04:12     INFO -   5  libxul.so + 0x29c275d
[task 2017-09-06T07:04:12.430393Z] 07:04:12     INFO -       sp = 0x528ff5dc    pc = 0x4308175f
[task 2017-09-06T07:04:12.430691Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.431096Z] 07:04:12     INFO -   6  libxul.so + 0x719c7
[task 2017-09-06T07:04:12.431386Z] 07:04:12     INFO -       sp = 0x528ff5e8    pc = 0x407309c9
[task 2017-09-06T07:04:12.431708Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.432065Z] 07:04:12     INFO -   7  libxul.so + 0x1c026ab
[task 2017-09-06T07:04:12.432372Z] 07:04:12     INFO -       sp = 0x528ff5f0    pc = 0x422c16ad
[task 2017-09-06T07:04:12.432634Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.432936Z] 07:04:12     INFO -   8  libxul.so + 0x29b97da
[task 2017-09-06T07:04:12.433218Z] 07:04:12     INFO -       sp = 0x528ff5fc    pc = 0x430787dc
[task 2017-09-06T07:04:12.433596Z] 07:04:12     INFO -      Found by: stack scanning
[task 2017-09-06T07:04:12.433855Z] 07:04:12     INFO -   9  libxul.so + 0x1c0291f
[task 2017-09-06T07:04:12.434252Z] 07:04:12     INFO -       sp = 0x528ff620    pc = 0x422c1921
[task 2017-09-06T07:04:12.434612Z] 07:04:12     INFO -      Found by: stack scanning

Comment 1

9 months ago
2 failures in 924 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api16: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397160&startday=2017-09-04&endday=2017-09-10&tree=all
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399773
You need to log in before you can comment on or make changes to this bug.