Closed Bug 1397169 Opened 2 years ago Closed 2 years ago

Clicking on an URL navigate the page inside the toolbox

Categories

(DevTools :: DOM, defect)

defect
Not set

Tracking

(firefox57 fixed)

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: nchevobbe, Assigned: Honza)

References

Details

Attachments

(1 file)

Steps to reproduce: 

1. Open the console
2. Evaluate the following code `window.mozilla = "http://mozilla.org"`
3. Go to the DOM panel
4. Search for "mozilla" in the filter input
5. Click on the "http://mozilla.org" link

Expected results:
The link is opened in a new tab

Actual results:
The DOM panel is replaced with the "http://mozilla.org" website

---

This is due to the fact that Reps rely on a openLink callback to open links. If the callback is not set, a simple <a> link is created, and clicking on it navigates to the page in place (we do want this behavior for the JSON panel).
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Comment on attachment 8904996 [details]
Bug 1397169 - Properly implement openLink;

https://reviewboard.mozilla.org/r/176838/#review181750

I see. It's an another similar openLink issue. Thanks for your quick fix. Honza!
Attachment #8904996 - Flags: review?(rchien) → review+
Thanks for the review Ricky!

Honza
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de7570a6289b
Properly implement openLink; r=rickychien
https://hg.mozilla.org/mozilla-central/rev/de7570a6289b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1397137
Duplicate of this bug: 1389486
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.