fix talos to run in develop mode on all try branch names, not just 'Try'

RESOLVED FIXED in Firefox 57

Status

Testing
Talos
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: jmaher, Unassigned)

Tracking

Trunk
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [PI:September])

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
http://searchfox.org/mozilla-central/search?q=Try%27&case=true&path=testing

I found that we were running tests on Try-Non-PGO so a lot of the logic for developers did not apply.  

we should look at the branch-name argument in a variety of try scenarios and ensure that we meet that inside of talos.
Comment hidden (mozreview-request)
Also, It isn't clear to me which kind of try push I should do for such patch?
try: -b o -p all -u none -t all ?
(Reporter)

Comment 3

10 months ago
mozreview-review
Comment on attachment 8905845 [details]
Bug 1397222 - Fix running talos in developer mode on try branches.

https://reviewboard.mozilla.org/r/177654/#review182724

one small change- otherwise this is simple and good.

how to test this?  This is one of those integrated between multiple systems/tools- possibly testing this with a hacked up patch that changes a pref so tests would intentionally fail:
http://searchfox.org/mozilla-central/source/testing/talos/talos/config.py#98

then push with both regular and pgo |try -b o -p linux64,linux64-pgo -u none -t other-e10s|

::: testing/talos/talos/ffsetup.py:97
(Diff revision 1)
>          extensions = self.browser_config['extensions'][:]
>          if self.test_config.get('extensions'):
>              extensions.append(self.test_config['extensions'])
>  
>          if self.browser_config['develop'] or \
> -           self.browser_config['branch_name'] == 'Try':
> +           'Try' in self.browser_config['branch_name']:

I would prefer if we had:
'try' in str.lower(self.browser_config['branch_name'])

I saw a recent bug fix which required checking for both since it has 'try' and needed to check for 'Try' as well.
Attachment #8905845 - Flags: review?(jmaher) → review-
Comment hidden (mozreview-request)
(Reporter)

Comment 5

10 months ago
mozreview-review
Comment on attachment 8905845 [details]
Bug 1397222 - Fix running talos in developer mode on try branches.

https://reviewboard.mozilla.org/r/177654/#review182738

thanks for doing this!
Attachment #8905845 - Flags: review?(jmaher) → review+

Comment 7

10 months ago
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e87c726ee91
Fix running talos in developer mode on try branches. r=jmaher
https://hg.mozilla.org/mozilla-central/rev/8e87c726ee91
Status: NEW → RESOLVED
Last Resolved: 10 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.