<title/>-tag causes page not to be rendered.

RESOLVED DUPLICATE of bug 139298

Status

()

Core
XML
RESOLVED DUPLICATE of bug 139298
16 years ago
15 years ago

People

(Reporter: Tomas Kindahl, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; FreeBSD i386; U;) Gecko/0
BuildID:    20020423

<title/> in <head> causes the page not to be rendered. <title></title> works ok.
The document validates as correct xhtml 1.0, or so validator.w3.org says.

Mozilla version 1.0rc1, using galeon as frontend.

Reproducible: Always
The page is served as text/html, so we parse it according to HTML rules (this is
the right thing to do according to the XHTML spec).  In HTML, the trailing slash
means nothing, so that's an unclosed title tag.

The whole point of serving XHTML as text/html is to be compatible with browsers
that are HTML browsers (instead of XML browsers) and this page is totally not
doing that.... (see bug 135425 for more on this).



*** This bug has been marked as a duplicate of 139298 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.