When typing in urlbar or search box, box size increases

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: arno.lambin, Assigned: dao)

Tracking

({regression})

57 Branch
Firefox 57
Unspecified
All
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ fixed)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170905220108

Steps to reproduce:

Typpe some text in search box, using compact density layout.


Actual results:

When some text is entered in search box, it resizes the box (some pixels to the bottom). 


Expected results:

No height change should happen. It doesn't exists in normal density.
Component: Untriaged → Search

Comment 1

2 years ago
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Unspecified → Windows 10
Whiteboard: [photon-visual]

Comment 2

2 years ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2b0d4df90489db8e1922c28cf3c9fc973ce86d0b&tochange=31c8cec38f4677dd87156c8a0a55290f3fc1a67c

Regressed by: 31c8cec38f46	Drew Willcoxon — Bug 1388589 - Add Button States to Items in the Location Bar. r=dao
Blocks: 1388589
Whiteboard: [photon-visual] → [photon-visual] [triage]
Duplicate of this bug: 1397305
Component: Search → Theme

Comment 4

2 years ago
Marc, I noticed you duped https://bugzilla.mozilla.org/show_bug.cgi?id=1397305 here.
However, I was seeing the opposite problem: I had no issue with search box, but got some with the url bar.

Considering that, do you still think it's a dupe?
Flags: needinfo?(standard8)
(In reply to Clément Lefèvre from comment #4)
> Marc, I noticed you duped
> https://bugzilla.mozilla.org/show_bug.cgi?id=1397305 here.
> However, I was seeing the opposite problem: I had no issue with search box,
> but got some with the url bar.
> 
> Considering that, do you still think it's a dupe?

I would expect it to be likely - you were both using a compact layout, I suspect the styling of these boxes is actually the same. I'm a bit surprised it would affect one and not the other, lets see what Drew thinks.
Flags: needinfo?(standard8) → needinfo?(adw)
I see this too, in the urlbar.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
OS: Windows 10 → All
Summary: When typing in search box, box size increases → When typing in urlbar or search box, box size increases
(Assignee)

Updated

2 years ago
Whiteboard: [photon-visual] [triage] → [photon-structure][triage]
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]

Updated

2 years ago
Duplicate of this bug: 1397302

Comment 8

2 years ago
afaics this also happens in normal density, at least the urlbar height increase.

Comment 9

2 years ago
(In reply to matthias koplenig from comment #8)
> afaics this also happens in normal density, at least the urlbar height
> increase.

I couldn't reproduce it on Normal density while it's here on compact for OS X 10.9.
On macOS 10.12.6 i see the height increase, but since the toolbar has enough whitespace
around it's not that obvious.

the focus-ed state is at least 3px higher here.

Updated

2 years ago
Duplicate of this bug: 1397392

Comment 12

2 years ago
(In reply to matthias koplenig from comment #10)
> On macOS 10.12.6 i see the height increase, but since the toolbar has enough
> whitespace
> around it's not that obvious.

Please fix this regression. The increasing looks very strange :-(
Comment hidden (mozreview-request)
The problem is the go arrow image, in both the url and search bars.  It's a .urlbar-icon too, even in the search bar, and the rules that I added in bug 1388589 aren't right for it.

So what this does is to restore the rules to .urlbar-icon that I removed, and then adds the new rules only to .urlbar-icon.urlbar-page-action.

The animatable icons (bookmark star, Pocket) are trickier.  It doesn't seem necessary to have size and padding rules for their second images, the "animatable" ones.  In fact giving them sizes and padding in the CSS makes blank spots appear in the urlbar.  Another thing is their hover state.  Giving the animatable images a hover background reveals that they're actually slightly taller than the urlbar.  Giving the top-level hboxes (.urlbar-icon-wrapper) a background instead works.  So this patch fixes bug 1397395 too.

I noticed a couple of related problems.  One I filed as bug 1397583.  The other is that the active background color is not nearly different enough from the hover background.  It should be darker.  I'll file a new bug for that.
Also seeing this toolbar expansion when just clicking on the urlbar from the newtab page, also using compact tabs.
(Assignee)

Comment 16

2 years ago
I'll try to review this tomorrow. Didn't get to it today.

Comment 17

2 years ago
still reproducible under 57.0a1 (2017-09-11) just when writing some text. both compact and normal, all three themes.
Duplicate of this bug: 1399016

Updated

2 years ago
Duplicate of this bug: 1398128

Updated

2 years ago
Duplicate of this bug: 1398695

Updated

2 years ago
Duplicate of this bug: 1398059
(Assignee)

Comment 22

2 years ago
mozreview-review
Comment on attachment 8905346 [details]
Bug 1397278 - When typing in urlbar or search box, box size increases.

https://reviewboard.mozilla.org/r/177136/#review183766

::: browser/themes/shared/urlbar-searchbar.inc.css:171
(Diff revision 1)
>    fill: currentColor;
>    fill-opacity: 0.6;
>    color: inherit;
> +}
> +
> +.urlbar-icon.urlbar-page-action,

I think we want treat all urlbar-icons the same here. See also bug 1394137 comment 2.
Attachment #8905346 - Flags: review?(dao+bmo) → review-
(Assignee)

Comment 23

2 years ago
(In reply to Drew Willcoxon :adw from comment #14)
> The problem is the go arrow image, in both the url and search bars.  It's a
> .urlbar-icon too, even in the search bar, and the rules that I added in bug
> 1388589 aren't right for it.

I have a patch that I think should address the Go button issue more directly. I can't reproduce this bug on Linux so I'll still need to test it on Windows.
Duplicate of this bug: 1399122
new regression in 57, lots of duplicates, tracking.

Comment 27

2 years ago
mozreview-review
Comment on attachment 8907063 [details]
Bug 1397278 - Move the urlbar-go-button node to make its layout work more consistently with other urlbar-icons, and remove obsolete search-go-container padding.

https://reviewboard.mozilla.org/r/178786/#review183898

Nicer, thanks
Attachment #8907063 - Flags: review?(adw) → review+

Updated

2 years ago
Assignee: adw → dao+bmo
(Assignee)

Updated

2 years ago
Attachment #8905346 - Attachment is obsolete: true

Comment 28

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97299b4db298
Move the urlbar-go-button node to make its layout work more consistently with other urlbar-icons, and remove obsolete search-go-container padding. r=adw
https://hg.mozilla.org/mozilla-central/rev/97299b4db298
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1399610
I have reproduced this bug with Nightly 57.0a1 (2017-09-06) in Windows 10 (64-bit).

This bug's fix is verified with latest Nightly 57.0a1 (64-bit).

Build ID   :   20170914100122
User Agent :   Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday 20170913]
Status: RESOLVED → VERIFIED
Flags: qe-verify?

Updated

2 years ago
Duplicate of this bug: 1398740
You need to log in before you can comment on or make changes to this bug.