Update expires_in_version of RCWN related probes

RESOLVED FIXED in Firefox 57

Status

()

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: michal, Assigned: michal)

Tracking

Trunk
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(2 attachments)

Expiration version should be updated for following probes:

HTTP_NET_VS_CACHE_ONSTART_NOTREVALIDATED_V2
HTTP_NET_VS_CACHE_ONSTART_QBIG_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTART_QBIG_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTART_QMED_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTART_QMED_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTART_QSMALL_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTART_QSMALL_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTART_REVALIDATED_V2
HTTP_NET_VS_CACHE_ONSTOP_LARGE_V2
HTTP_NET_VS_CACHE_ONSTOP_NOTREVALIDATED_V2
HTTP_NET_VS_CACHE_ONSTOP_QBIG_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_QBIG_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_QMED_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_QMED_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_QSMALL_HIGHPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_QSMALL_NORMALPRI_V2
HTTP_NET_VS_CACHE_ONSTOP_REVALIDATED_V2
HTTP_NET_VS_CACHE_ONSTOP_SMALL_V2
HTTP_ONSTART_SUSPEND_TOTAL_TIME
Posted patch patchSplinter Review
Attachment #8905078 - Flags: review?(valentin.gosu)
Attachment #8905078 - Flags: review?(valentin.gosu) → review+
Pushed by mnovotny@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/74a3b5e1f809
Update expires_in_version of RCWN related probes, r=valentin
https://hg.mozilla.org/mozilla-central/rev/74a3b5e1f809
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
It appears as though this patch landed without data review. Data review by a Data Peer or Owner [1] is required for extending expiry on data collection (the original reviews are valid for only the original expiry date).

[1]: https://wiki.mozilla.org/Firefox/Data_Collection
Flags: needinfo?(michal.novotny)
Flags: needinfo?(michal.novotny)
Attachment #8905078 - Flags: review?(rweiss)
:michal, can you add an attachment to this bug with answers to the 8 questions listed here: 
https://docs.google.com/document/d/1SSn5w8DfCSkHWJS8DNTd7ya82diWRxaDUFM5aL4UDDo/edit

You can group all of the telemetry probes into the one form, these all look like they will be category 1.
Flags: needinfo?(michal.novotny)
Flags: needinfo?(michal.novotny)
Comment on attachment 8905078 [details] [diff] [review]
patch

Review of attachment 8905078 [details] [diff] [review]:
-----------------------------------------------------------------

1) Is there documentation that describes the schema for the ultimate data set available publicly, complete and accurate? 
Yes, these will be part of Histograms.json.

2) Is there a control mechanism that allows the user to turn the data collection on and off?
Yes, the Telemetry preference will cover this data.

3) If the request is for permanent data collection, is there someone who will monitor the data over time?
Not permanent.

4) Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under? 
Type 1.

5) Is the data collection default-on or default-off? 
Default on.

6) Does the instrumentation include the addition of any new identifiers (whether anonymous or otherwise; e.g., username, random IDs, etc. See the appendix for more details)? 
No new identifiers.

7) Is the data collection covered by the existing Firefox privacy notice? If unsure: escalate to legal.
Yes.

8) Does there need to be a check-in in the future to determine whether to renew the data? 
Yes, there will be, but as Category 1 data, this can be covered with a simple request for renewal.
Attachment #8905078 - Flags: review?(rweiss) → review+
Duplicate of this bug: 1398207
You need to log in before you can comment on or make changes to this bug.