Closed Bug 1397382 Opened 3 years ago Closed 3 years ago

llvm-dsymutil valgrind failure with rust 1.20.0

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1381043

People

(Reporter: rillian, Unassigned)

References

Details

Bumping rust to 1.20.0 in bug 1396884 fails the macOS cross opt target. Another dsymutil crash.

Build log: https://treeherder.mozilla.org/logviewer.html#?job_id=128946531&repo=autoland

[task 2017-09-06T16:03:10.886278Z] 16:03:10     INFO -  #50 0x000000000042aa4d llvm::dsymutil::(anonymous namespace)::DwarfLinker::link(llvm::dsymutil::DebugMap const&) (/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil+0x42aa4d)
[task 2017-09-06T16:03:10.886554Z] 16:03:10     INFO -  #51 0x00000000004285b9 llvm::dsymutil::linkDwarf(llvm::StringRef, llvm::dsymutil::DebugMap const&, llvm::dsymutil::LinkOptions const&) (/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil+0x4285b9)
[task 2017-09-06T16:03:10.886786Z] 16:03:10     INFO -  #52 0x000000000041b938 main (/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil+0x41b938)
[task 2017-09-06T16:03:10.887020Z] 16:03:10     INFO -  #53 0x00007ff370b34d1d __libc_start_main (/lib64/libc.so.6+0x1ed1d)
[task 2017-09-06T16:03:10.887297Z] 16:03:10     INFO -  #54 0x000000000041b1d9 _start (/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil+0x41b1d9)
[task 2017-09-06T16:03:10.887547Z] 16:03:10     INFO -  Stack dump:
[task 2017-09-06T16:03:10.887812Z] 16:03:10     INFO -  0.	Program arguments: /builds/worker/workspace/build/src/clang/bin/llvm-dsymutil --arch=x86_64 /builds/worker/workspace/build/src/obj-firefox/toolkit/library/XUL
[task 2017-09-06T16:03:10.888090Z] 16:03:10     INFO -  Error running dsymutil: Command '['/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil', '--arch=x86_64', '/builds/worker/workspace/build/src/obj-firefox/toolkit/library/XUL']' returned non-zero exit status -11
[task 2017-09-06T16:03:10.888296Z] 16:03:10     INFO -  Traceback (most recent call last):
[task 2017-09-06T16:03:10.888520Z] 16:03:10     INFO -    File "/builds/worker/workspace/build/src/toolkit/crashreporter/tools/symbolstore.py", line 888, in <module>
[task 2017-09-06T16:03:10.888755Z] 16:03:10     INFO -      main()
[task 2017-09-06T16:03:10.889048Z] 16:03:10     INFO -    File "/builds/worker/workspace/build/src/toolkit/crashreporter/tools/symbolstore.py", line 884, in main
[task 2017-09-06T16:03:10.889263Z] 16:03:10     INFO -      dumper.Process(args[2])
[task 2017-09-06T16:03:10.889539Z] 16:03:10     INFO -    File "/builds/worker/workspace/build/src/toolkit/crashreporter/tools/symbolstore.py", line 501, in Process
[task 2017-09-06T16:03:10.889766Z] 16:03:10     INFO -      self.ProcessFile(file_to_process)
[task 2017-09-06T16:03:10.890061Z] 16:03:10     INFO -    File "/builds/worker/workspace/build/src/toolkit/crashreporter/tools/symbolstore.py", line 758, in ProcessFile
[task 2017-09-06T16:03:10.890290Z] 16:03:10     INFO -      dsymbundle = self.GenerateDSYM(file)
[task 2017-09-06T16:03:10.890561Z] 16:03:10     INFO -    File "/builds/worker/workspace/build/src/toolkit/crashreporter/tools/symbolstore.py", line 792, in GenerateDSYM
[task 2017-09-06T16:03:10.890813Z] 16:03:10     INFO -      subprocess.check_call(cmd, stdout=open(os.devnull, 'w'))
[task 2017-09-06T16:03:10.891029Z] 16:03:10     INFO -    File "/usr/lib/python2.7/subprocess.py", line 540, in check_call
[task 2017-09-06T16:03:10.891198Z] 16:03:10     INFO -      raise CalledProcessError(retcode, cmd)
[task 2017-09-06T16:03:10.891431Z] 16:03:10     INFO -  subprocess.CalledProcessError: Command '['/builds/worker/workspace/build/src/clang/bin/llvm-dsymutil', '--arch=x86_64', '/builds/worker/workspace/build/src/obj-firefox/toolkit/library/XUL']' returned non-zero exit status -11
Who is looking into this failure? This is starting to block work in Servo and WebRender.
This is essentially a dupe of bug 1381043, which has an analysis of the crash, an upstream llvm bug link. The latter has some level of explanations as to what rust is doing wrong, but we can cherry-pick the llvm patch and apply it to our clang.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381043
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.