hover state is missing for bookmarked pages in location bar

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: soeren.hentzschel, Assigned: adw)

Tracking

unspecified
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Bug 1388589 added button states to the items in the location bar, including the bookmark star. But there is only a grey background on hover if the page is *not* bookmarked. *If* the page is bookmarked there is no grey background hover.

There should probably be a hover state in both cases.
Whiteboard: [photon-structure][triage]
(Assignee)

Comment 1

2 years ago
Thanks for filing this.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
(Assignee)

Comment 2

2 years ago
My patch in bug 1397278 fixes this.
(Assignee)

Comment 3

2 years ago
Bug 1397278 will end up getting fixed a different way after all, so I'll need to fix this bug separately.  Working on a patch.
Comment hidden (mozreview-request)
(Assignee)

Comment 5

2 years ago
A few options I can think of:

(1) Add rules specifically for #star-button-animatable-image and #pocket-animatable-image

(2) Add a new .urlbar-animatable-icon class, set it on #star-button-animatable-image and #pocket-animatable-image

(3) Apply hover rule to .urlbar-icon-wrapper itself instead of the images in it

This patch does (3).  (2) and (3) seem better than (1) since they're general.  (3) seems better than (2) since it doesn't require a new class.

I noticed that the corners of the background of the last icon in the urlbar overlap the urlbar's rounded corners.  It's hard to see in light mode, but it's obvious in dark mode.  I'll file a separate bug for that.
(Assignee)

Comment 6

2 years ago
(In reply to Drew Willcoxon :adw from comment #5)
> I noticed that the corners of the background of the last icon in the urlbar
> overlap the urlbar's rounded corners.  It's hard to see in light mode, but
> it's obvious in dark mode.  I'll file a separate bug for that.

bug 1399235
Comment hidden (mozreview-request)
(Assignee)

Comment 8

2 years ago
Forgot to set the background transition on .urlbar-icon-wrapper.

Updated

2 years ago
Attachment #8907243 - Flags: review?(dao+bmo) → review?(gijskruitbosch+bugs)

Comment 9

2 years ago
mozreview-review
Comment on attachment 8907243 [details]
Bug 1397395 - hover state is missing for bookmarked pages in location bar.

https://reviewboard.mozilla.org/r/178916/#review184282

Stealing this because I saw it through bug 1399235 anyway - r=me
Attachment #8907243 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 10

2 years ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b01eb1d915f8
hover state is missing for bookmarked pages in location bar. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/b01eb1d915f8
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
I have reproduced this issue on an affected Nightly 57.0a1 (2017-09-06) using info provided in comment 0.

Not reproducible anymore on 57.0b6 (20171005195903) under Windows 10 x64, Mac OS X 10.11 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.