unable to reply to post at answers.microsoft.com with AdBlock Plus add-on enabled

RESOLVED DUPLICATE of bug 1379148

Status

()

RESOLVED DUPLICATE of bug 1379148
a year ago
a year ago

People

(Reporter: witchsue11, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

On answers.microsoft.com at this link

https://answers.microsoft.com/en-us/outlook_com/forum/oemail-ocompose/can-no-longer-expand-group-to-show-all-email/50cf8ce5-822e-44d8-8c15-3a6b2a741c6e?auth=1

Click on reply to leave a reply to a previous post - a semi transparent white overlay covers the page.  It prevents me leaving a reply.

Adblock Plus development build 2.99.0.1832 beta
Filters are easylist and adblock warning removal list
Firefox 55.0.3 32 bit


Actual results:

If ABP is either enabled or disabled by clicking on the APB icon and choosing disable on this site, even with a restart I am unable to leave a reply in the thread, a semi transparent white overlay covers the page. 

Only if I go to Firefox - add-ons - and completely disable ABP and restart Firefox am I able to leave a reply. 

Further info from mapx at the AdBlock plus forum.......

Well, it's weird.
In FF 54 + the legacy ABP is working fine.

In FF 56 - even disabling the adblocker and restating FF - does not work.
Could be some FF regression due to the new extensions system.


Expected results:

I should have been able to leave a reply using Firefox 55.0.3 without having to disable AdBlock Plus and restarting Firefox.  The site worked well with all previous versions of Firefox up to 54.
Please report the issue to the extension author. Thank you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 2

a year ago
It's not an extension issue.

Use for example FF 56.0b9 (64-bit)
Disable your adblocker(s) (from add-ons page).

Go to https://answers.microsoft.com/en-us/outlook_com/forum/oemail-ocompose/can-no-longer-expand-group-to-show-all-email/50cf8ce5-822e-44d8-8c15-3a6b2a741c6e?auth=1

Click Reply ==> on page overlay will appear. 

No such issue using chrome browser.
In which case the author of ABP will be able to explain exactly what it's doing to cause this issue and raise his own bug describing in much more detail what Firefox add-on API functions are being called that cause this. If you can do that you can reopen the bug.

Comment 4

a year ago
ok, it's not about ABP.

It happens whatever extension you have enabled (tested with ABP / uBo / tampermonkey).

So, probably is still this bug ==> https://bugzilla.mozilla.org/show_bug.cgi?id=1379148

So, it's not invalid but duplicate.

Comment 5

a year ago
I'm having this same problem which appears to be caused by the add-ons uBlock Origin and Bitwarden.  When I disable both of them the page loads.  Experimented on a clean profile with only these two add-ons.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Comment 6

a year ago
uBlock Origin release nots. ( see https://github.com/gorhill/uBlock/releases/tag/1.14.8 )
Bug 1396226 and dup Bug 1379148.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1379148
You need to log in before you can comment on or make changes to this bug.