Closed Bug 1397401 Opened 3 years ago Closed 3 years ago

[macOS] [Photon] Regression: Window Traffic Lights are no longer vertically centered

Categories

(Firefox :: Theme, defect, P1)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: mehmet.sahin, Assigned: johannh)

References

Details

(Keywords: polish, regression, Whiteboard: [reserve-photon-visual][fixed by bug 1349552])

Attachments

(1 file)

Attached image actual_vs_expected.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3207.0 Safari/537.36

Steps to reproduce:

57.0a1 (2017-09-06) (64-Bit)
macOS 10.12.6

1.) Take a look at the Window Traffic Lights


Actual results:

They should be vertically aligned.


Expected results:

They are not aligned.

This is a regression. It is aligned in Firefox Stable (Non-Photon-UI).

A screenshot attached.
Component: Untriaged → Theme
OS: Unspecified → Mac OS X
Can you check when this regressed? I bet this is also caused by bug 1383051 (like bug 1396281) but it'd be good to be sure.
Blocks: 1383051
Flags: needinfo?(mehmet.sahin)
(In reply to :Gijs from comment #1)
> Can you check when this regressed? I bet this is also caused by bug 1383051
> (like bug 1396281) but it'd be good to be sure.

It happened between build [good] 57.0a1 (2017-08-10) (64-bit) and build [bad] 57.0a1 (2017-08-11) (64-bit).

In this range there must be a patch, that fixed the tabstrip background height. The background height was increased but the vertical alignment of the Window Traffic Lights haven't been adjusted.

I hope this helps :-)
Flags: needinfo?(mehmet.sahin)
(In reply to :Gijs from comment #1)
> Can you check when this regressed? I bet this is also caused by bug 1383051
> (like bug 1396281) but it'd be good to be sure.

Pretty sure this is not is since bug 1383051 only landed on 2017-09-01.
No longer blocks: 1383051
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e8471e20d775f1ab3e142b7ace0073eac53f557b&tochange=4c274336b01e08b29fb17c2df311bfb63243a50c

Kind of sad that that bug has screenshots links which should have caused this to be picked up, but it clearly wasn't...
Blocks: 1386964
Whiteboard: [photon-visual][triage]
(In reply to :Gijs from comment #4)
> https://hg.mozilla.org/integration/autoland/
> pushloghtml?fromchange=e8471e20d775f1ab3e142b7ace0073eac53f557b&tochange=4c27
> 4336b01e08b29fb17c2df311bfb63243a50c
> 
> Kind of sad that that bug has screenshots links which should have caused
> this to be picked up, but it clearly wasn't...

To be fair, in hindsight it's much easier to realize that the window controls should change along with the rest of the tabstrip (I didn't notice it either when triaging the screenshots).
(In reply to Johann Hofmann [:johannh] from comment #5)
> (In reply to :Gijs from comment #4)
> > https://hg.mozilla.org/integration/autoland/
> > pushloghtml?fromchange=e8471e20d775f1ab3e142b7ace0073eac53f557b&tochange=4c27
> > 4336b01e08b29fb17c2df311bfb63243a50c
> > 
> > Kind of sad that that bug has screenshots links which should have caused
> > this to be picked up, but it clearly wasn't...
> 
> To be fair, in hindsight it's much easier to realize that the window
> controls should change along with the rest of the tabstrip (I didn't notice
> it either when triaging the screenshots).

Oh, right, I guess this is something that stayed the same but should have changed, which, uh, yeah, we can't really have alerts for that. :-(
Flags: qe-verify+
Priority: -- → P3
QA Contact: ovidiu.boca
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
I'll probably solve this in bug 1349552.
Assignee: nobody → jhofmann
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: P3 → P1
Iteration: --- → 57.3 - Sep 19
Depends on: 1349552
Keywords: polish
Can you check that bug 1349552 resolved this for you? It should be fixed in the very latest Nightly (the one that has drag space in the customize menu).
Flags: needinfo?(mehmet.sahin)
I see this fixed, too.
That's enough for me :)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mehmet.sahin)
Resolution: --- → FIXED
Whiteboard: [reserve-photon-visual] → [reserve-photon-visual][fixed by bug 1349552]
(In reply to Johann Hofmann [:johannh] from comment #8)
> Can you check that bug 1349552 resolved this for you? It should be fixed in
> the very latest Nightly (the one that has drag space in the customize menu).

Perfect! Thank you very much. It is looking very fine now again in every state Compact/Normal/+Drag_Space :-)
Target Milestone: --- → Firefox 57
See Also: → 1331105
I tested this issue on Mac OS X 10.10 with FF Nightly 58.0a1(2017-10-15) and FF beta 57.0b8, I can't reproduce this issue. Based on this I will mark it as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.