Closed Bug 1397427 Opened 3 years ago Closed 3 years ago

Enable py2 linter on tools/tryselect

Categories

(Testing :: General, enhancement)

enhancement
Not set

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: ahal, Assigned: akriti.v10, Mentored)

References

Details

(Whiteboard: [good-first-bug])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1397423 +++

The linter can be enabled by removing 'tools/tryselect' from the exclude section in tools/lint/py2.yml.

You can then see all the errors by running:
./mach lint -l py2 tools/tryselect

Each of the errors will need to be fixed before this can land.

To test changes, please be sure to run both:
./mach lint --outgoing
./mach cram tools/tryselect

to be sure nothing else broke.
Hi, can i try this?
Hi akriti, sure!

You can submit your patch as an attachment to this bug if you like, or (preferably) you can push it to mozreview, our code review tool. See here for instructions setting it up:
http://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview-user.html

Please format your commit message like:
<Bug> - <message>, r=ahal

If you need any other help, feel free to comment here or e-mail me. There's also a ton of information on mdn:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Introduction

Once I see a patch I'll assign you the bug. Thanks for your interest!
Hi Andrew, I ran this command -"./mach lint -l py2 tools/tryselect" after removing tools/tryselect from py2.yml and i got this 
error "ImportError: No module named python.compat" .
Strange, is it possible that you're using an older version of mozilla-central? Can you verify that this file exists:
https://dxr.mozilla.org/mozilla-central/source/tools/lint/python/compat.py

If it doesn't (or if it's called something else), you might need to pull mozilla-central and update to the latest revision.
It seems i am using an old version of mozilla-central because the "python" folder is missing from my local copy of "lint".
Hi Andrew, I have updated mozilla-central to the latest revision and now i have the required files. Thanks for suggesting that.

After running the first two commands i got an error which i removed and now it shows '0 problems' but when i run the third command - "./mach cram tools/tryselect" , i get the following result

"It looks like you are trying to run an unknown mach command: cram

Did you want to run any of these commands instead: cramtest?

Run |mach help| to show a list of commands.
"

On running "./mach cramtest tools/tryselect" ,i am getting some errors one of which is "-NoSectionError: No section: u'fuzzy'-"
Oh, hm. Ok let's not worry too much about that then (it's a new test suite, so there might be a bug in it somewhere). I'll make sure it runs on try server. As long as the lint command passes, you'll probably be ok. If you have a patch, you can upload it if you like. Do you need help getting set up with mozreview?

There's documentation here:
http://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview.html
Assignee: nobody → akriti.v10
Status: NEW → ASSIGNED
Comment on attachment 8907429 [details]
Bug 1397427 - Enable py2 linter on tools/tryselect,

https://reviewboard.mozilla.org/r/179114/#review184960

Thanks, this looks good! I'll trigger some try jobs and if everything looks ok, I'll land it then.
Attachment #8907429 - Flags: review?(ahalberstadt) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c50e8581fed
Enable py2 linter on tools/tryselect, r=ahal
https://hg.mozilla.org/mozilla-central/rev/5c50e8581fed
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Thanks for your contribution akriti! If you'd like to keep working on stuff like this, or want to try something a little different, please let me know.
Hi Andrew,thanks for your support and guidance, while i was working on this bug. I would certainly like to fix more bugs of this kind but currently i am working on something else. As soon as it is over i will message you again for more work on lint.
You need to log in before you can comment on or make changes to this bug.