Closed Bug 1397525 Opened 2 years ago Closed 2 years ago

Can't go back after going to about:home in non-e10s

Categories

(Firefox :: Tabbed Browser, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 - fixed

People

(Reporter: Oriol, Assigned: mconley)

References

Details

(Keywords: regression)

Attachments

(1 file)

1. Disable e10s
2. Load http://example.com
3. Right-click the "More information..." link, open it in a new tab
4. Focus that new tab
5. Click the home button in the toolbar
6. Attempt to click the Back button in the toolbar

Expected: you can go back
Result: the Back button is greyed out. Note that history.back() does work.

I get this error in the browser console:

    window.content is null
    onLocationChange chrome://browser/content/browser.js:4739:1
    callListeners chrome://browser/content/tabbrowser.xml:483:24
    _callProgressListeners chrome://browser/content/tabbrowser.xml:498:13
    _callProgressListeners chrome://browser/content/tabbrowser.xml:586:22
    onLocationChange chrome://browser/content/tabbrowser.xml:921:17

Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a3f57d191ae26e1357d681730998688514722855&tochange=51ae9cd5f5130686b226cb06b862ef37d1604c4c

I suspect bug 1385453.
The optimization landed in bug 1385453 was disabled in bug 1394455. Are you still experiencing this bug in a recent Nightly?
Flags: needinfo?(oriol-bugzilla)
I'm still experiencing the issue in latest Nightly (2017-09-08 50857982881ae7803ceb438fee90650a282f7f05).
Maybe it wasn't bug 1385453, then.
Flags: needinfo?(oriol-bugzilla)
Okay, unwiring bugs.
No longer blocks: 1385453
The pushlog has changes from these other bugs:

 - Bug 1355721 is a stylo thing. I still have the problem after disabling layout.css.servo.enabled
 - Bug 1389625 only changes some labels
 - Bug 1390140 is an android thing
 - Bug 1393355 just moves some selection code
 - Bug 1392919 is about playing media

Only bug 1385453 remains. Seems the culprit because it modifies tabbrowser.xml, and the error I see in the console comes from there.

So I think the problem was caused by bug 1385453. Then bug 1394455 disabled the pref but did not revert all changes from bug 1385453, so the problem remains.
I ran the STR in comment 0 and noticed that if I use the keyboard to switch tabs (which bypasses any of the warming paths), this bug does not exist. So that bolsters that this is caused by bug 1385453.

Investigating.
Assignee: nobody → mconley
Blocks: 1385453
Comment on attachment 8906685 [details]
Bug 1397525 - Don't instantiate async tab switcher when checking for tab warm-ability with e10s disabled.

https://reviewboard.mozilla.org/r/178404/#review183388
Attachment #8906685 - Flags: review?(florian) → review+
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45fc09022ed0
Don't instantiate async tab switcher when checking for tab warm-ability with e10s disabled. r=florian
https://hg.mozilla.org/mozilla-central/rev/45fc09022ed0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have reproduced this bug with Nightly 57.0a1 (2017-09-06) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20171102181127
User Agent    Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20171108]
You need to log in before you can comment on or make changes to this bug.