Closed Bug 1397530 Opened 2 years ago Closed 2 years ago

pollEmailStatus swallows exceptions checking the account state

Categories

(Firefox :: Firefox Accounts, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: markh, Assigned: markh)

Details

Attachments

(1 file)

Due to some other reason I'm still tracking down, we were attempting to check our email status when we didn't have a session token. The exception caused by this wasn't reported anywhere.
Assignee: nobody → markh
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8905308 [details]
Bug 1397530 - report all exceptions checking the account status.

https://reviewboard.mozilla.org/r/177104/#review182358

That looks good, thank you!
Attachment #8905308 - Flags: review?(eoger) → review+
Pushed by mhammond@skippinet.com.au:
https://hg.mozilla.org/integration/autoland/rev/c70b23f06f9f
report all exceptions checking the account status. r=eoger
https://hg.mozilla.org/mozilla-central/rev/c70b23f06f9f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Product: Core → Firefox
Target Milestone: mozilla57 → Firefox 57
You need to log in before you can comment on or make changes to this bug.