If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash on View Image, with close() called from onblur handler

VERIFIED DUPLICATE of bug 132534

Status

SeaMonkey
General
--
major
VERIFIED DUPLICATE of bug 132534
16 years ago
12 years ago

People

(Reporter: D Holroyd, Assigned: Matti)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build ID: 2002041711  (Moz 1.0RC1)

1) Visit the above URL
2) Right-click the image and select View Image
3) Crash

Talkback Ids: TB5557504X, TB5557477W

In the above page, the body tag calls a javascript function that in turn calls
self.close()
(Reporter)

Comment 1

16 years ago
I meant to say "the body tag's onblur handler calls..."
Doron, could you get the stacks?
Keywords: crash, stackwanted

Comment 3

16 years ago
confirm on rc1 (2002041711) & win2k (same as submitter)
TB5568235Q

Comment 4

16 years ago
Created attachment 80809 [details]
Reduced HTML testcase

Comment 5

16 years ago
Created attachment 80810 [details]
WinNT stack trace

Comment 6

16 years ago
Confirming crash using current Mozilla trunk binaries and
debug builds on WinNT. Here is the source of the HTML testcase:


<html><head><title>Bug 139756</title></head>
<body onBlur ='self.close();'>
  <img SRC="http://www.mozilla.org/images/mozilla-banner.gif">
</body></html>


The WinNT stack trace I've attached above is the same as
the Talkback incidents. I crash by loading the testcase and
following step 2 above:

2) Right-click the image and select View Image


One can also crash in Mozilla by loading the testcase and doing
View Page Source. Try that in IE6; you get an alertbox warning you
that the page is trying to close itself -

I'm not sure of the correct component; a lot of the stack trace
involves XUL document stuff. Totally unsure of who handles this;
would Boris know? 

In the meantime, this doesn't appear to be a JS Engine bug.
Reasssigning to Browser-General; please reassign as necessary -
Assignee: rogerl → Matti
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Browser-General
Ever confirmed: true
QA Contact: pschwartau → imajes-qa

Updated

16 years ago
Keywords: stackwanted
Ah, fun.  We already have a bug on this (same stack, same situation)

*** This bug has been marked as a duplicate of 132534 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Boris: thanks! Verified Duplicate.

mnkyglnds@hotmail.com: you have been cc'ed on the duplicate bug
so you can follow its progress -
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.