On OS X and Linux disable update staging via the app.update.staging.enabled preference

RESOLVED FIXED in Firefox 57

Status

()

Firefox
Preferences
RESOLVED FIXED
9 months ago
6 months ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 wontfix, firefox57 fixed)

Details

Attachments

(1 attachment)

Update staging has already been disabled on Windows due to bug 1368600, bug 1370576, and a few other bugs that were outside of app update's control.

On OS X there is bug 1123698 and Bug 1395415.
On Linux there is bug 1396460.

The only thing that staging provides is a slightly faster update experience at the cost of additional complexity. Until there is time / resources available to make staging updates as reliable as the normal update path update staging should be disabled on all platforms and not just Windows as was done in bug 1370576.
Created attachment 8905324 [details] [diff] [review]
patch rev1

Note: I would like to uplift this to beta as well.
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8905324 - Flags: review?(mhowell)
status-firefox56: --- → affected
status-firefox57: --- → affected

Updated

9 months ago
Attachment #8905324 - Flags: review?(mhowell) → review+

Comment 2

9 months ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/10c02a1f786d
Disable update staging on OS X and Linux via the app.update.staging.enabled preference. r=mhowell
cc'ing a couple of Thunderbird devs so they can port this if they would like to.
Duplicate of this bug: 1395415
Thank you Robert. I filed bug 1397862 for TB.
https://hg.mozilla.org/mozilla-central/rev/10c02a1f786d
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Comment 7

8 months ago
Too late for 56. Mass won't fix for 56.
status-firefox56: affected → wontfix
Duplicate of this bug: 1417060
You need to log in before you can comment on or make changes to this bug.